Bug 157293 - Multiple definitions of Gtk::RadioAction::Group
Multiple definitions of Gtk::RadioAction::Group
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkmm24 (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-10 05:54 EDT by Ignacio Vazquez-Abrams
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-11 10:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove extra member in Gtk::RadioAction (403 bytes, patch)
2005-05-10 05:54 EDT, Ignacio Vazquez-Abrams
no flags Details | Diff

  None (edit)
Description Ignacio Vazquez-Abrams 2005-05-10 05:54:55 EDT
There are 2 definitions of Gtk::RadioAction::Group in
/usr/include/gtkmm24/radioaction.h. One is at line 88, and the other at line
101. Although this does not interfere with GCC 3.x, it does trip up GCC 4. Patch
attached.
Comment 1 Ignacio Vazquez-Abrams 2005-05-10 05:54:55 EDT
Created attachment 114196 [details]
Patch to remove extra member in Gtk::RadioAction
Comment 2 Denis Leroy 2005-05-10 10:21:38 EDT
Yup. This was fixed in a later version of gtkmm, but still affects FC3 (because
the 2.4 to 2.6 updates are only available for FC4).

However, upgrading from 2.4.8 to to 2.4.11 will fix this problem. I'll check in
an update in the FC3 branch.
Comment 3 Denis Leroy 2005-05-11 10:41:33 EDT
2.4.11 build succeeded for FC3. :-)

Note You need to log in before you can comment on or make changes to this bug.