Bug 15730 - Unable to apply latest security update
Unable to apply latest security update
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
: Security
: 15783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-08 11:25 EDT by adam.huffman
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-09 08:23:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2000-08-08 11:25:27 EDT
When I try to upgrade to the latest perl package, as listed in the advisory
[RHSA-2000:048-02] on a 6.2 system, I get the following error:

bash# rpm -Uvh perl-5.00503-11.i386.rpm 
error: failed dependencies:
	rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by perl-5.00503-11
bash# rpm -q rpm
rpm-3.0.4-0.48
Comment 1 Jan Carlson 2000-08-08 13:20:43 EDT
I see exactly the same problem here.
Comment 2 Nalin Dahyabhai 2000-08-08 15:08:24 EDT
These dependencies are provided for by RPM 3.0.5, which we are currently working
on.
Comment 3 Philip Rowlands 2000-08-08 15:52:16 EDT
For the benefit of others reading this bug report, newer versions of the rpm
package can be downloaded from ftp://ftp.rpm.org/pub/rpm/dist/

I have rpm-3.0.5-7.6x.i386.rpm installed, which will take the updated perl RPM
as released in the original advisory. Take caution though, RPM 3.0.5 might not
be considered a production release; it has segfaulted on me once or twice.
Comment 4 Cristian Gafton 2000-08-08 22:45:35 EDT
assigned to nalin
Comment 5 Need Real Name 2000-08-09 00:15:58 EDT
*** Bug 15783 has been marked as a duplicate of this bug. ***
Comment 6 Hugh Bragg 2000-08-09 08:23:33 EDT
Same Here!

Why release a patch if it can't be used?
I guess anyone with a RedHat system will have to consider their system unsafe
until the new rpm package is released as production software.
Comment 7 Nalin Dahyabhai 2000-08-10 18:57:07 EDT
The new version of rpm required to install the package has now been released as
an errata.

Note You need to log in before you can comment on or make changes to this bug.