Red Hat Bugzilla – Bug 15730
Unable to apply latest security update
Last modified: 2008-05-01 11:37:57 EDT
When I try to upgrade to the latest perl package, as listed in the advisory
[RHSA-2000:048-02] on a 6.2 system, I get the following error:
bash# rpm -Uvh perl-5.00503-11.i386.rpm
error: failed dependencies:
rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by perl-5.00503-11
bash# rpm -q rpm
I see exactly the same problem here.
These dependencies are provided for by RPM 3.0.5, which we are currently working
For the benefit of others reading this bug report, newer versions of the rpm
package can be downloaded from ftp://ftp.rpm.org/pub/rpm/dist/
I have rpm-3.0.5-7.6x.i386.rpm installed, which will take the updated perl RPM
as released in the original advisory. Take caution though, RPM 3.0.5 might not
be considered a production release; it has segfaulted on me once or twice.
assigned to nalin
*** Bug 15783 has been marked as a duplicate of this bug. ***
Why release a patch if it can't be used?
I guess anyone with a RedHat system will have to consider their system unsafe
until the new rpm package is released as production software.
The new version of rpm required to install the package has now been released as