Bug 15730 - Unable to apply latest security update
Summary: Unable to apply latest security update
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
Keywords: Security
: 15783 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2000-08-08 15:25 UTC by adam.huffman
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-08-09 12:23:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description adam.huffman 2000-08-08 15:25:27 UTC
When I try to upgrade to the latest perl package, as listed in the advisory
[RHSA-2000:048-02] on a 6.2 system, I get the following error:

bash# rpm -Uvh perl-5.00503-11.i386.rpm 
error: failed dependencies:
	rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by perl-5.00503-11
bash# rpm -q rpm

Comment 1 Jan Carlson 2000-08-08 17:20:43 UTC
I see exactly the same problem here.

Comment 2 Nalin Dahyabhai 2000-08-08 19:08:24 UTC
These dependencies are provided for by RPM 3.0.5, which we are currently working

Comment 3 Philip Rowlands 2000-08-08 19:52:16 UTC
For the benefit of others reading this bug report, newer versions of the rpm
package can be downloaded from ftp://ftp.rpm.org/pub/rpm/dist/

I have rpm-3.0.5-7.6x.i386.rpm installed, which will take the updated perl RPM
as released in the original advisory. Take caution though, RPM 3.0.5 might not
be considered a production release; it has segfaulted on me once or twice.

Comment 4 Cristian Gafton 2000-08-09 02:45:35 UTC
assigned to nalin

Comment 5 Need Real Name 2000-08-09 04:15:58 UTC
*** Bug 15783 has been marked as a duplicate of this bug. ***

Comment 6 Hugh Bragg 2000-08-09 12:23:33 UTC
Same Here!

Why release a patch if it can't be used?
I guess anyone with a RedHat system will have to consider their system unsafe
until the new rpm package is released as production software.

Comment 7 Nalin Dahyabhai 2000-08-10 22:57:07 UTC
The new version of rpm required to install the package has now been released as
an errata.

Note You need to log in before you can comment on or make changes to this bug.