Bug 1573069 - hosted-engine --deploy ignores "None" settings for iSCSI auth / login in answers file [NEEDINFO]
Summary: hosted-engine --deploy ignores "None" settings for iSCSI auth / login in answ...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Ido Rosenzwig
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 06:02 UTC by Sam McLeod
Modified: 2018-05-02 22:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 07:36:13 UTC
oVirt Team: Integration
mailinglists: needinfo?


Attachments (Terms of Use)

Description Sam McLeod 2018-04-30 06:02:29 UTC
Description of problem:

hosted-engine --deploy ignores "None" settings for iSCSI auth / login in answers file

Version-Release number of selected component (if applicable):

ovirt-hosted-engine-setup-2.2.16-1.el7.centos.noarch

How reproducible:

Every time

Steps to Reproduce:
1. As an example, provide an answers file containing:

OVEHOSTED_STORAGE/iSCSIDiscoverUser=none:None
OVEHOSTED_STORAGE/iSCSIDiscoverPassword=none:None
OVEHOSTED_STORAGE/iSCSIPortalUser=none:None
OVEHOSTED_STORAGE/iSCSIPortalPassword=none:None

2. Run hosted-engine --deploy --config-append=<your answers file>


Actual results:

You will be prompted to enter the following:

Please specify the iSCSI discover user:
Please specify the iSCSI discover password:
Please specify the iSCSI portal login user:
Please specify the iSCSI portal login password:

Expected results:

These should all be skipped (null/empty/none) if None is provided in the answers file.

Additional info:

Note: if an empty `=str:` value is provided in the answers file, the install actually crashes with:

[ ERROR ] fatal: [localhost]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: 'None' has no attribute 'split'\n\nThe error appears to
 have been in '/usr/share/ovirt-hosted-engine-setup/ansible/create_storage_domain.yml': line 71, column 5, but may\nbe elsewhere in the file depending on the exact syntax probl
em.\n\nThe offending line appears to be:\n\n    register: otopi_storage_domain_details\n  - name: Add iSCSI storage domain\n    ^ here\n"}

Comment 1 Yaniv Lavi 2018-04-30 07:27:15 UTC
We do not not support not using authentication.
This is by design.

Comment 2 Sam McLeod 2018-04-30 21:58:38 UTC
(In reply to Yaniv Lavi from comment #1)
> We do not not support not using authentication.
> This is by design.

I'm not trying to use authentication.

The oVirt hosted-engine --deploy is _offering_ to use authentication.

Comment 3 Ido Rosenzwig 2018-05-01 07:36:13 UTC
If you don't want to use authentication you can add the answerfile the following lines:

OVEHOSTED_STORAGE/iSCSIDiscoverUser=str:
OVEHOSTED_STORAGE/iSCSIDiscoverPassword=str:
OVEHOSTED_STORAGE/iSCSIPortalUser=str:
OVEHOSTED_STORAGE/iSCSIPortalPassword=str:

This way you will not be asked about users and passwords.

Comment 4 Sam McLeod 2018-05-02 22:27:16 UTC
There is still a bug here - the generated answers file puts these values in with none:None, so if they're meant to be str: then it's doing it wrong.


Note You need to log in before you can comment on or make changes to this bug.