Bug 1573106 - [v2v] [RFE] Migration task failure status should provide specific error message
Summary: [v2v] [RFE] Migration task failure status should provide specific error message
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: GA
: cfme-future
Assignee: Dan Clarizio
QA Contact: Mor
URL:
Whiteboard: v2v
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 08:13 UTC by Mor
Modified: 2018-07-31 03:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-31 03:57:39 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)
automation and import log (5.39 MB, application/zip)
2018-04-30 08:13 UTC, Mor
no flags Details

Description Mor 2018-04-30 08:13:29 UTC
Created attachment 1428703 [details]
automation and import log

Description of problem:
When a failed migration task occur, MIQ UI provides a general error message for the failure. For example: 'VM Transformations failed'. 

It would be nice if we could get a reason for the failure, or aggregated errors from engine/host logs that relates to it. Currently, we need to dig the logs to find the root cause, which makes troubleshooting harder.

Version-Release number of selected component (if applicable):
MIQ master.20180417121918_2dd64f8 

How reproducible:
If failure occurs.

Steps to Reproduce:
1. Generate migration task which leads to VM transformation failure.

Actual results:
General error message.

Expected results:
Should be specific error message.

Additional info:

Comment 2 Gilles Dubreuil 2018-07-09 04:44:37 UTC
As we discussed in BZ#1597471 the tasks are purposefully working in asynchronous mode in order to not block the UI. Therefore feedback from the tasks are visible in the tasks list.

In order to make it clearer for the user, the initial request message could contain a explicit mention to the task list and a link to it.


Let's create a dedicated RFE to support this across the board.

Comment 4 Gilles Dubreuil 2018-07-31 03:57:39 UTC
This issue is also happening on other asynchronous tasks and the feature to enhance the user experience across all involved tasks is going to be taken care tracked with BZ#1597471.

Therefore closing this one.


Note You need to log in before you can comment on or make changes to this bug.