Bug 1573265 - IO Exception for ODL BGPConfigManager
Summary: IO Exception for ODL BGPConfigManager
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Ariel Adam
QA Contact: Itzik Brown
URL:
Whiteboard: DFG:ODL, scale_lab
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 16:44 UTC by Janki
Modified: 2018-10-14 09:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 07:58:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenDaylight Bug NETVIRT-988 0 None None None 2018-04-30 16:44:58 UTC

Description Janki 2018-04-30 16:44:07 UTC
Description of problem:
2018-04-30T14:47:26,505 | ERROR | opendaylight-cluster-data-akka.actor.default-dispatcher-41 | BgpConfigurationManager          | 342 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.redhat-8 | IO Exception got while activating mip: Cannot run program "cluster": error=2, No such file or directory
2018-04-30T14:47:26,511 | ERROR | BgpConfigurationManager-0 | BgpRouter                        | 342 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.redhat-8 | Invalid config server host: 255.255.255.255, port: 0


Version-Release number of selected component (if applicable):
ODL rpm 8.0.0.8

How reproducible:
Always

Steps to Reproduce:
1. Deploy Tripleo with ODL 8.0.0.8

Additional info:
Also seen with 8.0.0.5

Comment 1 Janki 2018-04-30 18:49:55 UTC
Adding TRACE Logs

2018-05-01T00:09:38,708 | TRACE | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | entity owner change event fired: EntityOwnershipChange [entity=Entity [type=bgp, id=KeyedInstanceIdentifier{targetType=interface org.opendaylight.yang.gen.v1.urn.opendaylight.params.xml.ns.yang.mdsal.core.general.entity.rev150930.Entity, path=[org.opendaylight.yang.gen.v1.urn.opendaylight.params.xml.ns.yang.mdsal.core.general.entity.rev150930.Entity[key=EntityKey [_name=bgp]]]}], state=REMOTE_OWNERSHIP_LOST_NO_OWNER [wasOwner=false, isOwner=false, hasOwner=false], inJeopardy=false]
2018-05-01T00:09:38,709 | DEBUG | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | Not owner: hasOwner: false, isOwner: false
2018-05-01T00:09:38,712 | TRACE | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | entity owner change event fired: EntityOwnershipChange [entity=Entity [type=bgp, id=KeyedInstanceIdentifier{targetType=interface org.opendaylight.yang.gen.v1.urn.opendaylight.params.xml.ns.yang.mdsal.core.general.entity.rev150930.Entity, path=[org.opendaylight.yang.gen.v1.urn.opendaylight.params.xml.ns.yang.mdsal.core.general.entity.rev150930.Entity[key=EntityKey [_name=bgp]]]}], state=LOCAL_OWNERSHIP_GRANTED [wasOwner=false, isOwner=true, hasOwner=true], inJeopardy=false]
2018-05-01T00:09:38,713 | TRACE | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | This PL is the Owner
2018-05-01T00:09:38,713 | TRACE | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | BgpReactor: Executing MIP Activate command
2018-05-01T00:09:38,686 | INFO  | Blueprint Extender: 3 | BgpConfigurationManager  | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | BGP Configuration manager initialized
2018-05-01T00:09:38,721 | ERROR | opendaylight-cluster-data-akka.actor.default-dispatcher-22 | BgpConfigurationManager | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | IO Exception got while activating mip: Cannot run program "cluster": error=2, No such file or directory
2018-05-01T00:09:38,748 | WARN  | Blueprint Extender: 1 | RpcServiceMetadata       | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | org.opendaylight.netvirt.fibmanager-impl (salGroupService): interface interface org.opendaylight.yang.gen.v1.urn.opendaylight.group.service.rev130918.SalGroupService has no accptable entries, assuming it is satisfied
2018-05-01T00:09:38,749 | WARN  | Blueprint Extender: 1 | RpcServiceMetadata       | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | org.opendaylight.genius.mdsalutil-impl (packetProcessingService): interface interface org.opendaylight.yang.gen.v1.urn.opendaylight.packet.service.rev130709.PacketProcessingService has no accptable entries, assuming it is satisfied
2018-05-01T00:09:38,754 | WARN  | Blueprint Extender: 1 | RpcServiceMetadata       | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | org.opendaylight.genius.alivenessmonitor-impl-protocols (packetProcessingService): interface interface org.opendaylight.yang.gen.v1.urn.opendaylight.packet.service.rev130709.PacketProcessingService has no accptable entries, assuming it is satisfied
2018-05-01T00:09:38,755 | INFO  | BgpConfigurationManager-0 | BgpConfigurationManager  | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | running bgp replay task
2018-05-01T00:09:38,755 | INFO  | Blueprint Extender: 3 | BgpManager      | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | BgpManager start
2018-05-01T00:09:38,757 | WARN  | Blueprint Extender: 1 | RpcServiceMetadata       | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | org.opendaylight.genius.interfacemanager-impl (opendaylightFlowTableStatisticsService): interface interface org.opendaylight.yang.gen.v1.urn.opendaylight.flow.table.statistics.rev131215.OpendaylightFlowTableStatisticsService has no accptable entries, assuming it is satisfied
2018-05-01T00:09:38,757 | WARN  | Blueprint Extender: 1 | RpcServiceMetadata       | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | org.opendaylight.genius.interfacemanager-impl (opendaylightPortStatisticsService): interface interface org.opendaylight.yang.gen.v1.urn.opendaylight.port.statistics.rev131214.OpendaylightPortStatisticsService has no accptable entries, assuming it is satisfied
2018-05-01T00:09:38,774 | INFO  | BgpConfigurationManager-0 | BgpConfigurationManager  | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | connecting  to bgp host 255.255.255.255
2018-05-01T00:09:38,774 | ERROR | BgpConfigurationManager-0 | BgpRouter       | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | Invalid config server host: 255.255.255.255, port: 0
2018-05-01T00:09:38,774 | INFO  | BgpConfigurationManager-0 | BgpConfigurationManager  | 335 - org.opendaylight.netvirt.bgpmanager-impl - 0.6.0.SNAPSHOT | no config to push in bgp replay task
2018-05-01T00:09:38,780 | INFO  | Blueprint Event Dispatcher: 1 | BlueprintBundleTracker   | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | Blueprint container for bundle org.opendaylight.controller.sal-binding-broker-impl_1.7.0.SNAPSHOT [214] was successfully created
2018-05-01T00:09:38,780 | INFO  | Blueprint Extender: 1 | BlueprintContainerImpl   | 79 - org.apache.aries.blueprint.core - 1.8.3 | Bundle org.opendaylight.aaa.shiro/0.7.0.SNAPSHOT is waiting for dependencies [(objectClass=org.opendaylight.aaa.cert.api.ICertificateManager)]
2018-05-01T00:09:38,796 | INFO  | Blueprint Event Dispatcher: 1 | BlueprintBundleTracker   | 193 - org.opendaylight.controller.blueprint - 0.8.0.SNAPSHOT | Blueprint container for bundle org.opendaylight.netvirt.bgpmanager-impl_0.6.0.SNAPSHOT [335] was successfully created

Comment 2 Itzik Brown 2018-05-01 08:09:58 UTC
Is there a functionality problem?

Comment 3 Janki 2018-05-03 09:47:44 UTC
This should not because we are not supporting BGP yet. But we should have a list of non-functional or false alarmed bugs listed out somewhere so when customers as we know that it exists and is harmless.

Comment 4 Mike Kolesnik 2018-05-07 07:58:44 UTC
Closing based on comment #3, if you see this directly causes any functional issue please reopen.


Note You need to log in before you can comment on or make changes to this bug.