Bug 1573266 - [RFE] vm reconfigure disk -> provide a way to customize on which datastore the new disk will be added
Summary: [RFE] vm reconfigure disk -> provide a way to customize on which datastore th...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.10.11
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: GA
: cfme-future
Assignee: Greg McCullough
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 16:44 UTC by Reartes Guillermo
Modified: 2019-12-18 14:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-18 14:32:58 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
current reconfigure vm add disk (46.68 KB, image/png)
2018-04-30 16:44 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2018-04-30 16:44:45 UTC
Created attachment 1428890 [details]
current reconfigure vm add disk

Description of RFE:

Currently, when one reconfigures a VM (adding a new disk, in this case), one can
only select the 'type' and 'size' and the size unit (MB/GB).

In my case, there are storage tiers (gold/silver/bronze) and it is important that the new disk is added in the right datastore.

I had to re-implement that feature on another custom button.

I request that "reconfigure vm, add disk" exposes in automate a way to change / replace the method in which it finds the datastore to which the new disk will be added.

I propose that the default method (it looks like the new disk is added on the same datastore) to be put on a method in automate.

The reconfigure vm add disk should not call it directly, but call an instance that points to it, so that one can add another method (which returns the 'datastore' where to add the disk) and replace the value on the instance.

Please note, i am just requesting that one can override the method that decides on which datastore to add the new disk.

Version-Release number of selected component (if applicable):
CloudForms 4.6

How reproducible:
N/A, since it is an RFE

Steps to Reproduce:
1. Go to a VM page
2. Click Configuration -> Reconfigure this VM
3. Click Add Disk
4. You can only select the type of disk and the size

Actual results:
one cannot add a "gold" disk (storage_gold CMDB attribute for the group of the user)

Expected results:
being able to override the method that returns which datastore to use for vm reconfigure disk

Additional info:
N/A, RFE


Note You need to log in before you can comment on or make changes to this bug.