Bug 1573306 - rhcert-ci clean and rhcert-cli clean don't have the same functionality
Summary: rhcert-ci clean and rhcert-cli clean don't have the same functionality
Keywords:
Status: NEW
Alias: None
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification
Version: 1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Greg Nichols
QA Contact: rhcert qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 19:57 UTC by Martin Kopec
Modified: 2018-04-30 19:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Kopec 2018-04-30 19:57:36 UTC
Description of problem:

In our job we ran rhcert tool like:
rhcert-ci clean all && rhcert-ci run --test self_check --test neutron_address_scope --test neutron_agents --test neutron_dhcp_extra --test neutron_flavor --test neutron_gateway_extra --test neutron_ip_availability --test neutron_l3_extra_route --test neutron_l3_flavors --test neutron_mtu --test neutron_rbac --test neutron_service_types --test neutron_subnet_allocation --test neutron_tags && rhcert-ci save

Then according to the test summary we saw, that director test failed, but there were no logs related to the director test. We assumed there were other runs in that machine. We tried to use 'rhcert-cli clean all' instead of 'rhcert-ci clean all' and it solved the issue, director test wasn't executed - as expected. 
Therefor it seems that rhcert-ci clean and rhcert-cli clean commands have a different behavior.


Version-Release number of selected component (if applicable):
latest in the time of creating the bug


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
rhcert-ci and rhcert-cli have a different functionality

Expected results:
rhcert-ci and rhcert-cli should behave the same


Note You need to log in before you can comment on or make changes to this bug.