Bug 1573336 - search cannot find “🤠” (U+1F920 FACE WITH COWBOY HAT) emoji
Summary: search cannot find “🤠” (U+1F920 FACE WITH COWBOY HAT) emoji
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-characters
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 21:43 UTC by Ben Liblit
Modified: 2018-08-06 08:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-06 08:06:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Liblit 2018-04-30 21:43:09 UTC
Description of problem:

I recently used the GNOME Characters application to search for an emoji wearing a cowboy hat.  Such an emoji does exist: “🤠”, also known as U+1F920 FACE WITH COWBOY HAT.  I can even see this emoji if I select the “Smileys & People” category and scroll down far enough: it's the 33rd item from the end.  However, I was unable to find it using any of the following search terms: “cow”, “cowboy”, “hat”, “face with”, even “🤠”.

By contrast, each of the preceding search terms does eventually reach the desired character when searching in the Character Map application.


Version-Release number of selected component (if applicable):

gnome-characters-3.26.2-1.fc27.x86_64


How reproducible:

100% reproducible.  Happens every time


Steps to Reproduce:
1. Launch GNOME Characters.
2. Press <Control>+F to activate the search field.
3. Type “cowboy” into this search field.

Actual results:

The application’s main display area reports “Search found no results” and “Try a different search.”


Expected results:

The application’s main display area should show the “🤠” emoji, also known as U+1F920 FACE WITH COWBOY HAT.

Comment 1 Ben Liblit 2018-05-01 21:52:39 UTC
Works as expected after upgrading the same machine to Fedora 28, which includes GNOME 3.28 and gnome-characters-3.28.0-1.fc28.x86_64.  Should we therefore close this bug report, or leave it open for a back-ported Fedora 27 (GNOME 3.26) fix?

Comment 2 Daiki Ueno 2018-08-06 08:06:45 UTC
It would be a bit of a task to backport it to F-27, because of the related dependency changes.  So let's close this bug.


Note You need to log in before you can comment on or make changes to this bug.