Bug 1573524 - [abrt] inode_io_list_move_locked: general protection fault in inode_io_list_move_locked [NEEDINFO]
Summary: [abrt] inode_io_list_move_locked: general protection fault in inode_io_list_m...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5c8e2eeef7fe6b3caa7401d6d85...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 15:28 UTC by Michael Catanzaro
Modified: 2018-08-29 15:05 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-29 15:05:00 UTC
Type: ---
jforbes: needinfo?


Attachments (Terms of Use)
File: dmesg (69.26 KB, text/plain)
2018-05-01 15:29 UTC, Michael Catanzaro
no flags Details

Description Michael Catanzaro 2018-05-01 15:28:55 UTC
Description of problem:
I ran the command:

$ rm -rf ~/.cache/buildstream
Segmentation fault

That was a surprising result: I've never seen rm crash before. It created one ABRT problem report, which is this one that I'm reporting now.

I tried again and my computer hung. After I force powered off, ABRT had created 22 new problem reports, none of which ABRT permits me to report, because "The backtrace does not contain enough meaningful function frames to be reported."

Additional info:
reporter:       libreport-2.9.3
general protection fault: 0000 [#1] SMP PTI
Modules linked in: fuse tun nf_conntrack_netbios_ns nf_conntrack_broadcast xt_CT ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ip_set nfnetlink ebtable_nat ebtable_broute bridge stp llc ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack libcrc32c iptable_mangle iptable_raw iptable_security ebtable_filter ebtables ip6table_filter ip6_tables sunrpc vfat fat intel_rapl x86_pkg_temp_thermal intel_powerclamp coretemp kvm_intel mei_wdt ppdev snd_hda_codec_hdmi kvm iTCO_wdt snd_hda_codec_realtek iTCO_vendor_support snd_hda_codec_generic snd_hda_intel snd_hda_codec irqbypass intel_cstate snd_usb_audio intel_uncore snd_hda_core snd_usbmidi_lib snd_rawmidi intel_rapl_perf
 snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer parport_pc mei_me parport snd i2c_i801 mei soundcore shpchp lpc_ich dm_crypt i915 i2c_algo_bit crct10dif_pclmul crc32_pclmul crc32c_intel drm_kms_helper drm r8169 ghash_clmulni_intel mii video
CPU: 4 PID: 17703 Comm: rm Not tainted 4.16.4-200.fc27.x86_64 #1
Hardware name: BIOSTAR Group B85MG/B85MG, BIOS 4.6.5 06/05/2014
RIP: 0010:__list_del_entry_valid+0x25/0x90
RSP: 0018:ffffb4188aed7dc0 EFLAGS: 00010206
RAX: ffff912a04e478d8 RBX: ffff912ac88d5c70 RCX: dead000000000200
RDX: fbff912a04e478d8 RSI: ffff912ac88d5c58 RDI: ffff912a04e478d8
RBP: ffff912a04e477e8 R08: 000000000002a200 R09: ffffffff98375013
R10: ffff912ac9469800 R11: ffff912ac946d800 R12: 0000000000000000
R13: ffff912ac88d5c58 R14: ffff912a04e478d8 R15: 0000000000000001
FS:  00007feb199f2500(0000) GS:ffff912adeb00000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 000055e851ea7068 CR3: 00000002b3154006 CR4: 00000000001606e0
Call Trace:
 inode_io_list_move_locked+0x30/0xc0
 __mark_inode_dirty+0x23d/0x390
 generic_update_time+0x9f/0xd0
 touch_atime+0xb2/0xe0
 iterate_dir+0x175/0x180
 SyS_getdents+0xa0/0x130
 ? fillonedir+0xe0/0xe0
 ? do_syscall_64+0x74/0x180
 do_syscall_64+0x74/0x180
 entry_SYSCALL_64_after_hwframe+0x3d/0xa2
RIP: 0033:0x7feb194f7dab
RSP: 002b:00007ffcc5b3ccd0 EFLAGS: 00000202 ORIG_RAX: 000000000000004e
RAX: ffffffffffffffda RBX: 000055e851c0c800 RCX: 00007feb194f7dab
RDX: 0000000000008000 RSI: 000055e851c0c800 RDI: 0000000000000003
RBP: 000055e851c0c800 R08: 0000000000000001 R09: 00007feb197e9d90
R10: 0000000000000000 R11: 0000000000000202 R12: ffffffffffffff80
R13: 0000000000000000 R14: 000055e851c0c7d0 R15: 000055e851c21648
Code: 84 00 00 00 00 00 48 8b 07 48 b9 00 01 00 00 00 00 ad de 48 8b 57 08 48 39 c8 74 26 48 b9 00 02 00 00 00 00 ad de 48 39 ca 74 2b <48> 8b 32 48 39 fe 75 34 48 8b 50 08 48 39 f2 75 3f b8 01 00 00 
RIP: __list_del_entry_valid+0x25/0x90 RSP: ffffb4188aed7dc0

Comment 1 Michael Catanzaro 2018-05-01 15:29:08 UTC
Created attachment 1429232 [details]
File: dmesg

Comment 2 Michael Catanzaro 2018-05-01 16:33:29 UTC
(In reply to Michael Catanzaro from comment #0)
> Description of problem:
> I ran the command:
> 
> $ rm -rf ~/.cache/buildstream
> Segmentation fault

nautilus says this directory contains 5,604,306 items totalling 160.7 GB. Took quite a while to count....

Comment 3 Justin M. Forbes 2018-07-23 15:09:34 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 27 kernel bugs.

Fedora 27 has now been rebased to 4.17.7-100.fc27.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 28, and are still experiencing this issue, please change the version to Fedora 28.

If you experience different issues, please open a new bug report for those.

Comment 4 Justin M. Forbes 2018-08-29 15:05:00 UTC
*********** MASS BUG UPDATE **************
This bug is being closed with INSUFFICIENT_DATA as there has not been a response in 5 weeks. If you are still experiencing this issue, please reopen and attach the relevant data from the latest kernel you are running and any data that might have been requested previously.


Note You need to log in before you can comment on or make changes to this bug.