Bug 157359 - libgsf doesn't include a .pc file for pkg-config
libgsf doesn't include a .pc file for pkg-config
Status: CLOSED DUPLICATE of bug 119701
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: libgsf (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-10 17:17 EDT by Adam Morley
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 09:12:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Morley 2005-05-10 17:17:00 EDT
libgsf-1.6.0-4 doesn't seem to include a pkg-config file so that pkg-config can
tell ./configure scripts where to find libgsf!  glib works great though.

[adam@sr0 evolution]$ pkg-config --libs gsf
Package gsf was not found in the pkg-config search path.
Perhaps you should add the directory containing `gsf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gsf' found
[adam@sr0 evolution]$ pkg-config --libs glib
-lglib
[adam@sr0 evolution]$ find /usr -name "*gsf*" 2>/dev/null |grep pc
[adam@sr0 evolution]$ find /usr -name "*glib*" 2>/dev/null |grep pc
/usr/lib/pkgconfig/glib.pc
/usr/lib/pkgconfig/glib-2.0.pc

this is on:
[adam@sr0 evolution]$ cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
[adam@sr0 evolution]$ uname -a
Linux sr0 2.4.21-27.0.4.ELsmp #1 SMP Sat Apr 16 18:43:06 EDT 2005 i686 i686 i386
GNU/Linux

(I'm not even sure if this really is a bug)

thanks!
adam

PS: I have support contracts
Comment 1 Suzanne Hillman 2005-05-11 11:21:49 EDT
As you mention having a support contract, if you are looking to get support,
rather than simply report a bug, you would be best off going to
http://www.redhat.com/support, or calling 888-REDHAT1
Comment 2 Adam Morley 2005-05-24 16:48:33 EDT
Hi,

I do have support, but it's through a hardware vendor.  And they don't know what
to do with bug reports for RedHat.  In fact, they don't know what to do with
RedHat service calls in general.

Is this the right place to submit such a bug report?  Or should I attempt to
convince my hardware vendor that it is a bug and they should care?

thanks,
adam
Comment 3 Suzanne Hillman 2005-05-25 10:38:26 EDT
This is the right place for a bug report, but not the right place for support. 

If all you are trying to do is report a bug, then this is the right place, and
thank you! 

If you need support, though, this is not the right place.
Comment 4 Adam Morley 2005-05-25 12:24:18 EDT
Cool.  I'm happy.  Fix it please?  ;-)
Comment 5 Vusa 2005-05-25 14:22:42 EDT
(In reply to comment #0)
This file should exist Adam, in 

/usr/lib/pkg-config as 

libgsf-1.pc

automake should be looking at that file for the gsf lib you are looking for.

If you run

pkg-config --libs libgsf-1.pc

you will get the Answer you are looking for!!!!


Sun Microsystems

> libgsf-1.6.0-4 doesn't seem to include a pkg-config file so that pkg-config can
> tell ./configure scripts where to find libgsf!  glib works great though.
> 
> [adam@sr0 evolution]$ pkg-config --libs gsf
> Package gsf was not found in the pkg-config search path.
> Perhaps you should add the directory containing `gsf.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'gsf' found
> [adam@sr0 evolution]$ pkg-config --libs glib
> -lglib
> [adam@sr0 evolution]$ find /usr -name "*gsf*" 2>/dev/null |grep pc
> [adam@sr0 evolution]$ find /usr -name "*glib*" 2>/dev/null |grep pc
> /usr/lib/pkgconfig/glib.pc
> /usr/lib/pkgconfig/glib-2.0.pc
> 
> this is on:
> [adam@sr0 evolution]$ cat /etc/redhat-release
> Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
> [adam@sr0 evolution]$ uname -a
> Linux sr0 2.4.21-27.0.4.ELsmp #1 SMP Sat Apr 16 18:43:06 EDT 2005 i686 i686 i386
> GNU/Linux
> 
> (I'm not even sure if this really is a bug)
> 
> thanks!
> adam
> 
> PS: I have support contracts

Comment 6 Adam Morley 2005-05-25 14:26:43 EDT
(In reply to comment #5)
> (In reply to comment #0)
> This file should exist Adam, in 

Huh?

> 
> /usr/lib/pkg-config as 
> 
> libgsf-1.pc

[adam@sr0 pkgconfig]$ uname -a
Linux sr0 2.4.21-32.ELsmp #1 SMP Fri Apr 15 21:17:59 EDT 2005 i686 i686 i386
GNU/Linux
[adam@sr0 pkgconfig]$ cd /usr/lib/pkg-config
bash: cd: /usr/lib/pkg-config: No such file or directory
[adam@sr0 pkgconfig]$ cd /usr/lib/pkgconfig/
[adam@sr0 pkgconfig]$ ls libgsf*
ls: libgsf*: No such file or directory


> 
> automake should be looking at that file for the gsf lib you are looking for.
> 
> If you run
> 
> pkg-config --libs libgsf-1.pc
> 
> you will get the Answer you are looking for!!!!

[adam@sr0 pkgconfig]$ pkg-config --libs libgsf-1.pc
Failed to open 'libgsf-1.pc': No such file or directory
No package 'libgsf-1.pc' found
[adam@sr0 pkgconfig]$ pkg-config --libs libgsf-1
Package libgsf-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgsf-1.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgsf-1' found
[adam@sr0 pkgconfig]$ pkg-config --libs libgsf
Package libgsf was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgsf.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgsf' found


> 
> 
> Sun Microsystems
> 
> > libgsf-1.6.0-4 doesn't seem to include a pkg-config file so that pkg-config can
> > tell ./configure scripts where to find libgsf!  glib works great though.
> > 
> > [adam@sr0 evolution]$ pkg-config --libs gsf
> > Package gsf was not found in the pkg-config search path.
> > Perhaps you should add the directory containing `gsf.pc'
> > to the PKG_CONFIG_PATH environment variable
> > No package 'gsf' found
> > [adam@sr0 evolution]$ pkg-config --libs glib
> > -lglib
> > [adam@sr0 evolution]$ find /usr -name "*gsf*" 2>/dev/null |grep pc
> > [adam@sr0 evolution]$ find /usr -name "*glib*" 2>/dev/null |grep pc
> > /usr/lib/pkgconfig/glib.pc
> > /usr/lib/pkgconfig/glib-2.0.pc
> > 
> > this is on:
> > [adam@sr0 evolution]$ cat /etc/redhat-release
> > Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
> > [adam@sr0 evolution]$ uname -a
> > Linux sr0 2.4.21-27.0.4.ELsmp #1 SMP Sat Apr 16 18:43:06 EDT 2005 i686 i686 i386
> > GNU/Linux
> > 
> > (I'm not even sure if this really is a bug)
> > 
> > thanks!
> > adam
> > 
> > PS: I have support contracts
> 
> 

Comment 7 Vusa 2005-05-25 14:48:42 EDT
/usr/lib/pkgconfig/

cd /usr/lib/pkgconfig/
[root@gillian pkgconfig]# ls libgsf*
libgsf-1.pc  libgsf-gnome-1.pc
[root@gillian pkgconfig]# 
Comment 8 Adam Morley 2005-05-25 15:08:25 EDT
(In reply to comment #7)
> /usr/lib/pkgconfig/
> 
> cd /usr/lib/pkgconfig/
> [root@gillian pkgconfig]# ls libgsf*
> libgsf-1.pc  libgsf-gnome-1.pc
> [root@gillian pkgconfig]# 

wha happen?  Is there are libgsf-devel?  If there is, why wasn't it installed
when I picked "everything" install?  I can't check, as rhn.redhat.com just told
me it's down and will be back later.

[root@sr0 pkgconfig]# rpm -qa |egrep "gsf"
libgsf-1.6.0-4
[root@sr0 pkgconfig]# rpm -qa |egrep "gsf|gnome"
gnome-python2-canvas-1.99.14-5
gnome-python2-1.99.14-5
switchdesk-gnome-3.9.8-17
gnome-desktop-2.2.2-1
libgail-gnome-1.0.2-1
libgnomecanvas-devel-2.2.0.2-2
gnome-mime-data-2.2.0-3
gnome-libs-devel-1.4.1.2.90-34.2
gnome-vfs2-2.2.5-2E.3.2
gnome-media-2.2.1.1-4.3
gnome-themes-2.2-3.1
gnome-terminal-2.2.2-1
libgnomeprint22-2.2.1.3-5
gnome-pilot-2.0.10-1
gnome-python2-bonobo-1.99.14-5
gnome-icon-theme-1.0.5-1.E
gnome-vfs2-extras-0.99.10-3
gnome-utils-2.2.3-1
libgnomeprintui22-2.2.1.3-2.0
gnome-user-docs-2.0.1-3
gnome-spell-1.0.5-1
libgnomeprintui22-devel-2.2.1.3-2.0
up2date-gnome-4.2.57-2
ethereal-gnome-0.10.11-1.EL3.1
gnome-applets-2.2.2-2.1E
gnome-python2-gtkhtml2-1.99.14-5
libgnomeui-2.2.1-1
gnome-session-2.2.2-3
gnomemeeting-0.96.0-4
libgnomeprint22-devel-2.2.1.3-5
libgnome-devel-2.2.2-6
libgnomeui-devel-2.2.1-1
gnome-libs-1.4.1.2.90-34.2
gnome-panel-2.2.2.1-10
openssh-askpass-gnome-3.6.1p2-33.30.4
libgnomecanvas-2.2.0.2-2
libgnome-2.2.2-6
gnome-system-monitor-2.0.5-2
gnome-games-2.2.1-1
gnome-vfs2-devel-2.2.5-2E.3.2
libgsf-1.6.0-4
gnome-audio-1.4.0-6
gnome-desktop-devel-2.2.2-1
redhat-switch-mail-gnome-0.5.20-1
gdk-pixbuf-gnome-0.22.0-12.el3
[root@sr0 pkgconfig]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 5)
Comment 9 Vusa 2005-05-25 15:20:47 EDT
[root@gillian pkgconfig]# rpm -qa libgsf
libgsf-1.6.0-4
[root@gillian pkgconfig]# more /etc/redhat-release 
Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
[root@gillian pkgconfig]# uname -a
Linux xxxxxxxxxxxx.sun.com 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004
i686 i686 i386 GNU/Linux
[root@gillian pkgconfig]# 


1st I would recommend you re-install the 

libgsf rpm and see if the problem continues..


Please advise if this is helpful
Comment 10 Adam Morley 2005-05-25 15:29:07 EDT
(In reply to comment #9)
> [root@gillian pkgconfig]# rpm -qa libgsf
> libgsf-1.6.0-4
> [root@gillian pkgconfig]# more /etc/redhat-release 
> Red Hat Enterprise Linux AS release 3 (Taroon Update 4)
> [root@gillian pkgconfig]# uname -a
> Linux xxxxxxxxxxxx.sun.com 2.4.21-20.ELsmp #1 SMP Wed Aug 18 20:46:40 EDT 2004
> i686 i686 i386 GNU/Linux
> [root@gillian pkgconfig]# 
> 
> 
> 1st I would recommend you re-install the 
> 
> libgsf rpm and see if the problem continues..
> 
> 
> Please advise if this is helpful


Sort of, but it's not in libgsf:

[adam@sr0 gsf]$ rpm2cpio ../libgsf-1.6.0-4.i386.rpm | cpio -id
287 blocks
[adam@sr0 gsf]$ ls -R
.:
usr
 
./usr:
lib  share
 
./usr/lib:
libgsf-1.so.1  libgsf-1.so.1.6.0  libgsf-gnome-1.so.1  libgsf-gnome-1.so.1.6.0
 
./usr/share:
doc
 
./usr/share/doc:
libgsf-1.6.0
 
./usr/share/doc/libgsf-1.6.0:
AUTHORS  COPYING  README

It is in libgsf-devel (see below), which didn't apparently exist when I did an
"everything" install of redhat 3 fcs.  or maybe it *was* in redhat 3 fcs's
libgsf package, but was later moved.  or maybe libgsf-devel was missed by
"everything" in redhat 3 fcs's installer?  So what other packages were not
installed/later moved/changed between redhat 3 fcs and redhat 3 u5?  because if
there is more than just libgsf-devel, I would like to know. . .

[adam@sr0 gsf-devel]$ rpm2cpio ../libgsf-devel-1.6.0-4.i386.rpm |cpio -id
895 blocks
[adam@sr0 gsf-devel]$ ls -R
.:
usr
 
./usr:
include  lib  share
 
./usr/include:
libgsf-1
 
./usr/include/libgsf-1:
gsf  gsf-gnome
 
./usr/include/libgsf-1/gsf:
gsf-doc-meta-data.h  gsf-input-memory.h    gsf-output.h
gsf.h                gsf-input-stdio.h     gsf-output-iochannel.h
gsf-impl-utils.h     gsf-input-textline.h  gsf-output-memory.h
gsf-infile.h         gsf-libxml.h          gsf-output-stdio.h
gsf-infile-msole.h   gsf-msole-utils.h     gsf-structured-blob.h
gsf-infile-msvba.h   gsf-outfile.h         gsf-timestamp.h
gsf-infile-zip.h     gsf-outfile-msole.h   gsf-utils.h
gsf-input-gzip.h     gsf-outfile-zip.h
gsf-input.h          gsf-output-gzip.h
 
./usr/include/libgsf-1/gsf-gnome:
gsf-input-bonobo.h    gsf-output-bonobo.h    gsf-shared-bonobo-stream.h
gsf-input-gnomevfs.h  gsf-output-gnomevfs.h
 
./usr/lib:
libgsf-1.a   libgsf-1.so       libgsf-gnome-1.la  pkgconfig
libgsf-1.la  libgsf-gnome-1.a  libgsf-gnome-1.so
 
./usr/lib/pkgconfig:
libgsf-1.pc  libgsf-gnome-1.pc
 
./usr/share:
doc
 
./usr/share/doc:
libgsf
 
./usr/share/doc/libgsf:
html
 
./usr/share/doc/libgsf/html:
gsf-gsf.html                 gsf-gsf-input-stdio.html     index.sgml  r299.html
gsf-gsf-impl-utils.html      gsf-gsf-input-textline.html  r1117.html  r329.html
gsf-gsf-infile.html          gsf-gsf-libxml.html          r1200.html  r415.html
gsf-gsfinfile.html           gsf-gsf-outfile.html         r1320.html  r501.html
gsf-gsf-infile-msole.html    gsf-gsf-output.html          r1384.html  r56.html
gsf-gsf-infile-zip.html      gsf-gsfoutput.html           r1414.html  r743.html
gsf-gsf-input-gnomevfs.html  gsf-gsf-shared-memory.html   r14.html    r858.html
gsf-gsf-input-gzip.html      gsf-gsf-utils.html           r1580.html  r876.html
gsf-gsf-input.html           gsf.html                     r1622.html  r962.html
gsf-gsfinput.html            i1823.html                   r1737.html
gsf-gsf-input-memory.html    index.html                   r175.html
Comment 11 Caolan McNamara 2005-05-31 09:12:12 EDT
the .pc is correctly part of the -devel package.

*** This bug has been marked as a duplicate of 119701 ***

Note You need to log in before you can comment on or make changes to this bug.