Bug 1573617 - Cloud Forms uninstall removes all PV's
Summary: Cloud Forms uninstall removes all PV's
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.9.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 19:19 UTC by Farid Saad
Modified: 2018-11-16 16:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-16 16:16:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Farid Saad 2018-05-01 19:19:01 UTC
Description of problem:
openshift-ansible cloudforms uninstall removes all PV's existing in the cluster (not just those related to its install).

Version-Release number of the following components:
rpm -q openshift-ansible = 3.9.14 (1.git.3.c62bc34.el7)
rpm -q ansible = 2.4.3 (1.el7ae)
ansible --version = 2.4.3.0

How reproducible:
Every time.

Steps to Reproduce:
1. Install OpenShift and any applications or additions with PV's
2. Install CloudForms using openshift-ansible
3. Uninstall Cloudforms and all PV's from the cluster will be gone

Actual results:
All cluster PV's will be gone.

Expected results:
Only PV's related to the openshift-management (cloudforms) project should be deleted, if any.

Additional info:
Looks like the bug has been fixed upstream but not pulled into the 3.9 RPM's:
https://github.com/openshift/openshift-ansible/commit/66d703c7eac00be57bdd8bc8c030b6231fd3d8ff#diff-fbd5a616f57125ea58278b14e1d677bc

Comment 1 Farid Saad 2018-05-02 13:41:26 UTC
I'd suggest to pull this to 3.7 and 3.6 as well as a lot of customers with these versions of OpenShift might end up attempting a CloudForms install and run the risk of blowing up potentially important data.

Comment 2 Russell Teague 2018-11-16 16:16:56 UTC
This bug was fixed in openshift-ansible-3.9.16-1

https://github.com/openshift/openshift-ansible/pull/7732


Note You need to log in before you can comment on or make changes to this bug.