Bug 1573672 - Massive upgrade issues 27->28
Summary: Massive upgrade issues 27->28
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-workstation-repositories
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 22:13 UTC by bugzilla.redhat.com@mno.pw
Modified: 2018-05-01 23:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 23:51:39 UTC
Type: Bug


Attachments (Terms of Use)
journalctl --since "2018-05-01 16:00:00" (8.38 MB, text/x-vhdl)
2018-05-01 22:13 UTC, bugzilla.redhat.com@mno.pw
no flags Details

Description bugzilla.redhat.com@mno.pw 2018-05-01 22:13:53 UTC
Created attachment 1429591 [details]
journalctl --since "2018-05-01 16:00:00"

Description of problem: Massive upgrade issues. Log output from journalctl --since "2018-05-01 16:00:00" is attached.

I've upgrade Fedora 27 to 28 today and there are quite some issues. Previous upgrade from Fedora 23 to 24, 24 to 25, 25 to 26 and 26 to 27 worked without any major issues.

I've upgraded my system using dnf following https://fedoraproject.org/wiki/DNF_system_upgrade

sudo dnf upgrade --refresh
reboot
sudo dnf install dnf-plugin-system-upgrade
sudo dnf system-upgrade download --refresh --releasever=28
sudo dnf system-upgrade reboot

I also did selinux relabel after I couldn't login using gnome.
sudo fixfiles onboot

After the relabeling (second restart after upgrade) the gnome welcome wizard came up asking me to add a new user. Definetly something I don't want because I already have a user. I disabled it by adding InitialSetupEnable=false to /etc/gdm/custom.conf. The dialog was disabled after reboot but I still cannot login using gnome.

1. After upgrade the gnome first rum wizard came up asking for adding another account
2. it is not possible to log into my account using gnome. Opening a terminal with shift alt fX, logging in and typing startx works but the system is quite buggy
3. settings crashes
4. chrome cannot open pages (nothing loads)
5. journalctl -xf shows tons output
6. NetworkManager-wait-online.service fails since performing the upgrade
~ systemctl status NetworkManager-wait-online.service
● NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2018-05-01 23:04:11 CEST; 1h 5min ago
     Docs: man:nm-online(1)
  Process: 1270 ExecStart=/usr/bin/nm-online -s -q --timeout=30 (code=exited, status=1/FAILURE)
 Main PID: 1270 (code=exited, status=1/FAILURE)

Mai 01 23:03:41 sven-laptop systemd[1]: Starting Network Manager Wait Online...
Mai 01 23:04:11 sven-laptop systemd[1]: NetworkManager-wait-online.service: Main process exited, code=exited, status=1/FAILURE
Mai 01 23:04:11 sven-laptop systemd[1]: NetworkManager-wait-online.service: Failed with result 'exit-code'.
Mai 01 23:04:11 sven-laptop systemd[1]: Failed to start Network Manager Wait Online.



Version-Release number of selected component (if applicable):
Fedora 28

How reproducible:
unknown

Actual results:
System unusable after upgrade

Expected results:
System should work just fine. Possibly some minor issues.

Additional info:
I've attached the log output from journalctl --since "2018-05-01 16:00:00". It is beginning like one or 2 hours before actually performing the upgrade.

Unfortunately I don't know where the best place to ask for help would be.

Comment 1 bugzilla.redhat.com@mno.pw 2018-05-01 22:42:07 UTC
Chrome started working after another reboot.

The login problem seems to be some issue with gdm. The following is the log output with debugging enabled while trying to login (~ journalctl -xf -u gdm.service)

Mai 02 00:37:02 sven-laptop gdm-password][5085]: GdmSessionWorker: trying to get updated username
Mai 02 00:37:02 sven-laptop gdm-password][5085]: GdmSessionWorker: PAM conversation returning 0: Success
Mai 02 00:37:02 sven-laptop unix_chkpwd[5104]: password check failed for user (shoeper)
Mai 02 00:37:02 sven-laptop gdm-password][5085]: pam_unix(gdm-password:auth): authentication failure; logname= uid=0 euid=0 tty=/dev/tty1 ruser= rhost=  user=shoeper
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: authentication returned 7: Authentication failure
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: uninitializing PAM
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: jumping to VT 1
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: first setting graphics mode to prevent flicker
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: couldn't set graphics mode: Inappropriate ioctl for device
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: VT mode did not need to be fixed
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: couldn't manage VTs manually: Inappropriate ioctl for device
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: couldn't initiate jump to VT 1: Inappropriate ioctl for device
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: state NONE
Mai 02 00:37:03 sven-laptop gdm-password][5085]: GdmSessionWorker: Unable to verify user
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmSession: stopping conversation gdm-password
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmSessionWorkerJob: Stopping job pid:5085
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmCommon: sending signal 15 to process 5085
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmSessionWorkerJob: child (pid:5085) done (status:0)
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmSession: Worker job exited: 0
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmSession: Emitting conversation-stopped signal
Mai 02 00:37:03 sven-laptop gdm[1266]: GdmManager: session conversation 'gdm-password' stopped
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmManager: trying to open reauthentication channel for user shoeper
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: starting conversation gdm-password
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSessionWorkerJob: Starting worker...
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSessionWorkerJob: Running session_worker_job process: gdm-session-worker [pam/gdm-password] /usr/libexec/gdm-session-worker
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSessionWorkerJob: : SessionWorkerJob on pid 5205
Mai 02 00:37:05 sven-laptop gdm-password][5205]: Enabling debugging
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: connecting to address: unix:abstract=/tmp/dbus-SEUajTDP
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmDBusServer: new connection 0x56086274ed80
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Handling new connection from worker
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Authenticating new connection
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: Failed to identify the current session: No data available
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: seat unloaded, so trying to set loaded property
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: Seat wouldn't load, so giving up on it and setting loaded property
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: already loaded, so not setting loaded property
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: worker connection is 0x56086274ed80
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Emitting conversation-started signal
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmManager: session conversation started for service gdm-password
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: checking if file 'gnome-xorg.desktop' is wayland session: no
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Setting user: 'shoeper'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Beginning initialization
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: getting session command for file 'gnome.desktop'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: checking if file 'gnome.desktop' is wayland session: yes
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: setting session to type 'wayland'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: getting session command for file 'gnome.desktop'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: Conversation started
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: trying to track new user with username shoeper
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: finding user 'shoeper' state 1
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: finding user 'shoeper' state 2
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: Looking for user 'shoeper' in accounts service
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: Found object path of user 'shoeper': /org/freedesktop/Accounts/User1000
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: finding user 'shoeper' state 3
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: user 'shoeper' fetched
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: user shoeper is now loaded
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: user shoeper was not yet known, adding it
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: tracking user 'shoeper'
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: not yet loaded, so not emitting user-added signal
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: no pending users, trying to set loaded property
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: already loaded, so not setting loaded property
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionSettings: saved session is gnome-xorg
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: Saved session is gnome-xorg
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionSettings: saved language is en_US.UTF-8
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: Saved language is en_US.UTF-8
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: queuing setup for user: shoeper (null)
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: finished handling request for user 'shoeper'
Mai 02 00:37:05 sven-laptop gdm-password][5205]: AccountsService: ActUserManager: unrefing manager owned by fetch user request
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: attempting to change state to SETUP_COMPLETE
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: initializing PAM; service=gdm-password username=shoeper seat=seat0
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: getting session command for file 'gnome-xorg.desktop'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: getting session command for file 'gnome.desktop'
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: checking if file 'gnome-xorg.desktop' is wayland session: no
Mai 02 00:37:05 sven-laptop gdm[1266]: GdmSession: setting session to type ''
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: Set PAM environment variable: 'XDG_SEAT=seat0'
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: state SETUP_COMPLETE
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: attempting to change state to AUTHENTICATED
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: authenticating user shoeper
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: 1 new messages received from PAM
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: username is 'shoeper'
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: old-username='shoeper' new-username='shoeper'
Mai 02 00:37:05 sven-laptop gdm-password][5205]: GdmSessionWorker: received pam message of type 1 with payload 'Password: '

Directly logging in from tty using the same user works as expected.

Comment 2 bugzilla.redhat.com@mno.pw 2018-05-01 23:51:39 UTC
Turns out that gnome login screen (gnome-shell?) ignores my keyboard layout. Even after changing it. It is neither an issue on tty nor while being logged in.

Closing this. Sorry for the spam - although this shouldn't have happened on upgrade.


Note You need to log in before you can comment on or make changes to this bug.