Bug 1573679 - [Netvirt][NAT][Scale] North-South UDP Traffic doesn't work when sender and receiver are on the same compute node
Summary: [Netvirt][NAT][Scale] North-South UDP Traffic doesn't work when sender and re...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: z4
: 13.0 (Queens)
Assignee: Aswin Suryanarayanan
QA Contact: Tomas Jamrisko
URL:
Whiteboard: Netvirt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 23:31 UTC by Sai Sindhur Malleni
Modified: 2019-01-15 11:37 UTC (History)
7 users (show)

Fixed In Version: opendaylight-8.3.0-3.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2019-01-15 11:37:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
compute-node-flows (38.89 KB, text/plain)
2018-05-01 23:31 UTC, Sai Sindhur Malleni
no flags Details

Description Sai Sindhur Malleni 2018-05-01 23:31:05 UTC
Description of problem: In a clustered ODL setup, we ran Browbeat data plane tests using shaker tool. The tools spawns two VMs on the same compute node. Each VM is on it's own private network connected to the public network via a neutron router. The iperf server has a private IP and Floating IP. The client has only a private IP. 

The master is the iperf server and the slave VM is the iperf client.



(overcloud) [stack@c08-h26-r630 ansible]$ openstack server list 
+--------------------------------------+------------------------+--------+----------------------------------------------+--------------+----------+
| ID                                   | Name                   | Status | Networks                                     | Image        | Flavor   |
+--------------------------------------+------------------------+--------+----------------------------------------------+--------------+----------+
| 8d2a6538-b723-496c-9ddf-697893f25aad | shaker_dzekam_slave_0  | ACTIVE | shaker_dzekam_net_south=10.2.0.7, 172.21.1.2 | shaker-image | m1.small |
| 22b2349f-c896-4a0c-847a-9bf4745964bb | shaker_dzekam_master_0 | ACTIVE | shaker_dzekam_net_north=10.1.0.5             | shaker-image | m1.small |
+--------------------------------------+------------------------+--------+----------------------------------------------+--------------+----------+
The VM with IP 10.1.0.5 runs iperf with the following command
 
 iperf3 --client 172.21.1.2 --format m --udp --bandwidth 0 --len 32 --time 60 --parallel 1 --interval 1 --json

UDP traffic doesn't work in this scenario

All other types of traffic work (TCP and ping) except UDP.

Version-Release number of selected component (if applicable):
OSP13
opendaylight-8.0.0-8.el7ost.noarch

How reproducible:
100% for UDP traffic in this traffic scenario

Steps to Reproduce:
1. Deploy Clustered ODL setup with OSP13
2. Run Browbeat+Shaker data plane tests for N-2 same compute scenarip
3.

Actual results:
UDP traffic doesn't work

Expected results:
UDP traffic has to work

Additional info:

Comment 1 Sai Sindhur Malleni 2018-05-01 23:31:41 UTC
Created attachment 1429605 [details]
compute-node-flows

Comment 4 Aswin Suryanarayanan 2018-08-03 10:03:44 UTC
When tested locally this use-case seems to be working fine. The local env was based on centos. A similar issue was observed in RHOS 12 time frame and the issue was related to the REHL kernel version , which seems to have a bug.

Further investigation is needed to check why only UDP north south is affected not other traffic.

Comment 6 Aswin Suryanarayanan 2018-10-30 06:05:55 UTC
The issue is not observed when tested with opendaylight-8.3.0-3.el7ost.noarch. The UDP traffic is successful when the NAPT switch is hosted on the same and when on a different node.

Comment 7 Lon Hohberger 2018-11-07 11:43:49 UTC
According to our records, this should be resolved by opendaylight-8.3.0-3.el7ost.  This build is available now.


Note You need to log in before you can comment on or make changes to this bug.