Bug 1573846 - Unable to start apache-2.4.33 server after installation- Cannot load modules/mod_ssl.so into server: libssl.so.1.0.0:
Summary: Unable to start apache-2.4.33 server after installation- Cannot load modules/...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: httpd
Version: 7.3
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Luboš Uhliarik
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 11:17 UTC by Anil
Modified: 2018-06-20 13:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 13:01:59 UTC
Target Upstream Version:


Attachments (Terms of Use)
Unable to start apache-2.4.33 server after installation- Cannot load modules/mod_ssl.so into server: libssl.so.1.0.0: (6.55 KB, image/png)
2018-05-02 11:17 UTC, Anil
no flags Details

Description Anil 2018-05-02 11:17:46 UTC
Created attachment 1429914 [details]
Unable to start apache-2.4.33 server after installation- Cannot load modules/mod_ssl.so into server: libssl.so.1.0.0:

Description of problem:Unable to start apache-2.4.33 server after installation of all dependent packages. while we try to start the server its giving error like "httpd: Syntax error on line 130 of /opt/SP/apache/httpd_current/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: libssl.so.1.0.0: cannot open shared object file: No such file or directory"


Version-Release number of selected component (if applicable):2.4.33


How reproducible: install packages and then httpd-apache package as below


Steps to Reproduce:
1. install openssl - 1.0.2o 
2. install apr - 1.6.3
3. install apr-util - 1.6.1
4. install pcre - 8.42
5. install libxml2 - 2.9.8(20908)
6. install httpd-apache - 2.4.33

Actual results:

ukpciqhr:apache:/opt/SP/apache $ /opt/SP/apache/httpd_current/bin/apachectl -k start
httpd: Syntax error on line 130 of /opt/SP/apache/httpd_current/conf/httpd.conf: Cannot load modules/mod_ssl.so into server: libssl.so.1.0.0: cannot open shared object file: No such file or directory
ukpciqhr:apache:/opt/SP/apache $

Expected results: should start properly 


Additional info:

Comment 2 Joe Orton 2018-06-20 13:01:42 UTC
Please only use Red Hat Bugzilla for reporting issues using software included in Red Hat Enterprise Linux.

Please contact Red Hat support if you need further assistance.


Note You need to log in before you can comment on or make changes to this bug.