Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573970 - dnf autoremove removes grouped packages
Summary: dnf autoremove removes grouped packages
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 15:38 UTC by Peter Oliver
Modified: 2018-09-25 16:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-25 16:12:15 UTC
Type: Bug


Attachments (Terms of Use)

Description Peter Oliver 2018-05-02 15:38:44 UTC
Description of problem:
After upgrading from Fedora 26 to 28, `dnf autoremove` wants to uninstall 670 packages, including packages that are part of installed groups, such as firefox and gnome-software.  Shouldn’t having a group installed protect the group's contents from auto-removal?

Version-Release number of selected component (if applicable):
dnf-2.7.5-12.fc28.noarch

How reproducible:
Always (on this system).

Steps to Reproduce:
> dnf group list | grep -B2 GNOME
Installed Groups:
   LibreOffice
   GNOME
> dnf group info GNOME | grep gnome-software
   gnome-software
> dnf list autoremove | grep gnome-software
gnome-software.x86_64                    3.28.1-1.fc28                  @fedora

Comment 1 Jaroslav Mracek 2018-09-25 16:12:15 UTC
I believe that the problem is not in the groups, but situation is caused by formal problem in dnf and inheritance of reasons especially in case of obsoletes.
To recover your system I would recommend to use "dnf mark install" command. I am sorry that probably all what we can do for you.


Note You need to log in before you can comment on or make changes to this bug.