Bug 1574161 - SELinux is preventing nm-ssh-service from 'open' accesses on the file /root/.config/user-dirs.dirs.
Summary: SELinux is preventing nm-ssh-service from 'open' accesses on the file /root/....
Keywords:
Status: CLOSED DUPLICATE of bug 1574162
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:0718aae47fe7f62aa6a75cb93e5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 18:18 UTC by Anass Ahmed
Modified: 2018-05-21 16:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-21 16:05:15 UTC
Type: ---


Attachments (Terms of Use)

Description Anass Ahmed 2018-05-02 18:18:38 UTC
Description of problem:
Trying to connect to SSH Tunnel using GNOME Network Manager SSH plugin.
SELinux is preventing nm-ssh-service from 'open' accesses on the file /root/.config/user-dirs.dirs.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that nm-ssh-service should be allowed open access on the user-dirs.dirs file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'nm-ssh-service' --raw | audit2allow -M my-nmsshservice
# semodule -X 300 -i my-nmsshservice.pp

Additional Information:
Source Context                system_u:system_r:NetworkManager_ssh_t:s0
Target Context                unconfined_u:object_r:config_home_t:s0
Target Objects                /root/.config/user-dirs.dirs [ file ]
Source                        nm-ssh-service
Source Path                   nm-ssh-service
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   1
First Seen                    2018-05-02 20:12:28 EET
Last Seen                     2018-05-02 20:12:28 EET
Local ID                      fd98bfdb-1a49-40ae-a340-044910653541

Raw Audit Messages
type=AVC msg=audit(1525284748.638:448): avc:  denied  { open } for  pid=14067 comm="nm-ssh-service" path="/root/.config/user-dirs.dirs" dev="sda2" ino=1308410 scontext=system_u:system_r:NetworkManager_ssh_t:s0 tcontext=unconfined_u:object_r:config_home_t:s0 tclass=file permissive=1


Hash: nm-ssh-service,NetworkManager_ssh_t,config_home_t,file,open

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-05-21 16:05:15 UTC

*** This bug has been marked as a duplicate of bug 1574162 ***


Note You need to log in before you can comment on or make changes to this bug.