Bug 1574260 - Upgrade Check fails on disk speed within documented limits
Summary: Upgrade Check fails on disk speed within documented limits
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Foreman Maintain
Version: 6.3.1
Hardware: All
OS: Linux
unspecified
low
Target Milestone: Unspecified
Assignee: Kavita
QA Contact: Nikhil Kathole
URL:
Whiteboard:
: 1630878 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 23:43 UTC by andthoma
Modified: 2020-03-05 17:28 UTC (History)
9 users (show)

Fixed In Version: rubygem-foreman_maintain-0.2.11
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-05 17:28:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 24976 0 Normal Closed For satellite 6.3 & 6.4 beta version, mentioned expected speed is a range 60 - 80 Megabytes per second in documentation 2020-11-23 09:02:07 UTC

Description andthoma 2018-05-02 23:43:10 UTC
Description of problem:

Running the command 'foreman-maintain upgrade check --target-version 6.3.z' on a Satellite with Mongo residing on storage at 60 Megabytes per second causes the check to fail.  The access article ( https://access.redhat.com/solutions/3397771 ) and the docs ( https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html/installation_guide/preparing_your_environment_for_installation#hardware_storage_prerequisites ) both state a requirement of 60 - 80 Megabytes per second.

Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.  Run 'foreman-maintain upgrade check --target-version 6.3.z' on a system with storage IO speeds of 61-64 Megabytes per second.
2.
3.

Actual results:

--------------------------------------------------------------------------------
Check for recommended disk speed of pulp, mongodb, pgsql dir.:
| Finished

/var/lib/pulp : 314 MB/sec
/var/lib/mongodb : 112 MB/sec
/var/lib/pgsql : 61 MB/sec                                            [FAIL]
Slow disk detected /var/lib/pgsql mounted on /dev/mapper/sat-var_lib_pgsql.
             Actual disk speed: 61 MB/sec
             Expected disk speed: 80 MB/sec.
--------------------------------------------------------------------------------



Expected results:

--------------------------------------------------------------------------------
Check for recommended disk speed of pulp, mongodb, pgsql dir.:
| Finished

/var/lib/pulp : 314 MB/sec
/var/lib/mongodb : 112 MB/sec
/var/lib/pgsql : 61 MB/sec                                            [OK]
--------------------------------------------------------------------------------


Additional info:

Comment 2 Kavita 2018-05-17 08:03:15 UTC
Thanks for reporting this issue.

As per me, there is inconsistency between documents. 
Once it is confirmed which value/range will be appropriate for comparison, it will be easy to move this BZ further.


In foreman-maintain, we have used value 80 MB/sec to compare it against actual disk speed of above directories.
This value added in foreman-maintain from satellite 6.2 documentation i.e https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/installation_guide/#upgrading_satellite_server_and_capsule_server

Where, it is mentioned that "A minimum of 80 MB/s Buffered Read Time is recommended for read access to the device used in the /var partition."


But under "Storage Recommendations" section of sat 6.3 documentation i.e
https://access.redhat.com/documentation/en-us/red_hat_satellite/6.3/html-single/installation_guide/#hardware_storage_prerequisites

as well as https://access.redhat.com/solutions/3397771, mentioned range is 60-80.

Comment 3 Kavita 2018-05-17 13:21:09 UTC
Hello Mike, any inputs for this BZ?

Comment 4 Mahesh Yadav 2018-09-18 10:00:19 UTC
Hello Team,

There is one more case has been reported for this.
Attaching Case ID herewith this bugzilla Case02182701

Could we have any update on this ?

Comment 5 Kavita 2018-09-20 08:02:03 UTC
*** Bug 1630878 has been marked as a duplicate of this bug. ***

Comment 6 Kavita 2018-09-20 08:05:57 UTC
I have considered latest threshold i.e >= 60 MB/s from sat 6.3

Comment 7 pm-sat@redhat.com 2018-09-21 10:08:51 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/24976 has been resolved.

Comment 8 Ivan Necas 2018-09-25 18:02:02 UTC
The fix is released as part of foreman-maintain-0.2.11 (packaging PR https://github.com/theforeman/foreman-packaging/pull/3037)

Comment 9 Mahesh Yadav 2018-11-28 14:47:24 UTC
Hello All,

Is there any update on this ?

Comment 10 Nikhil Kathole 2019-06-24 06:20:06 UTC
VERIFIED

Version tested:
rubygem-foreman_maintain-0.4.3-1.el7sat.noarch

Expected disk speed changed to 60 MB/sec


Running ForemanMaintain::Scenario::FilteredScenario
================================================================================
Check for recommended disk speed of pulp, mongodb, pgsql dir.: 
| Finished                                                                      

Disk speed : 36 MB/sec                                                [WARNING]
Slow disk detected /var/lib/pulp mounted on /dev/mapper/vg_dhcp201-lv_root.
             Actual disk speed: 36 MB/sec
             Expected disk speed: 60 MB/sec.
WARNING: Low disk speed might have a negative impact on the system.
See https://access.redhat.com/solutions/3397771 before proceeding
--------------------------------------------------------------------------------

Comment 11 Bryan Kearney 2020-03-05 17:28:34 UTC
The current version of foreman_maintain includes this fix.


Note You need to log in before you can comment on or make changes to this bug.