Bug 1574566 - csound: FTBFS - error: no matching function for call to 'lu_factor'
Summary: csound: FTBFS - error: no matching function for call to 'lu_factor'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: csound
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
: 1603721 (view as bug list)
Depends On:
Blocks: F29FTBFS
TreeView+ depends on / blocked
 
Reported: 2018-05-03 14:49 UTC by Jitka Plesnikova
Modified: 2019-06-18 21:19 UTC (History)
4 users (show)

Fixed In Version: csound-6.12.2-1.fc30 csound-6.12.2-1.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-18 18:13:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Jitka Plesnikova 2018-05-03 14:49:39 UTC
Description of problem:
Package csound fails to build from source in Fedora rawhide with following errors:

/builddir/build/BUILD/csound-6.10.0/Opcodes/linear_algebra.cpp:3930:45: error: no matching function for call to 'lu_factor(gmm::dense_matrix<double>&, std::vector<long unsigned int>&)'
     *ksize = gmm::lu_factor(lhs->mr, pivot__);
                                             ^
In file included from /usr/include/gmm/gmm_lapack_interface.h:42,
                 from /usr/include/gmm/gmm_kernel.h:52,
                 from /usr/include/gmm/gmm.h:40,
                 from /builddir/build/BUILD/csound-6.10.0/Opcodes/linear_algebra.cpp:371:

...

/builddir/build/BUILD/csound-6.10.0/Opcodes/linear_algebra.cpp:3958:45: error: no matching function for call to 'lu_factor(gmm::dense_matrix<std::complex<double> >&, std::vector<long unsigned int>&)'
     *isize = gmm::lu_factor(lhs->mc, pivot__);
                                             ^
In file included from /usr/include/gmm/gmm_lapack_interface.h:42,
                 from /usr/include/gmm/gmm_kernel.h:52,
                 from /usr/include/gmm/gmm.h:40,
                 from /builddir/build/BUILD/csound-6.10.0/Opcodes/linear_algebra.cpp:371:

Version-Release number of selected component (if applicable):
6.10.0-2.fc28

Steps to Reproduce:
koji build --scratch f29 csound-6.10.0-2.fc28.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/csound

Comment 1 Jan Kurik 2018-08-14 10:04:20 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 29 development cycle.
Changing version to '29'.

Comment 2 Jitka Plesnikova 2019-03-08 11:30:40 UTC
*** Bug 1603721 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2019-06-10 11:39:24 UTC
FEDORA-2019-3183d15fb0 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3183d15fb0

Comment 4 Fedora Update System 2019-06-11 01:19:08 UTC
csound-6.12.2-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-09b532ae92

Comment 5 Fedora Update System 2019-06-11 01:45:29 UTC
csound-6.12.2-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3183d15fb0

Comment 6 Fedora Update System 2019-06-18 18:13:55 UTC
csound-6.12.2-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2019-06-18 21:19:04 UTC
csound-6.12.2-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.