Bug 1574785 - unable to update hostgroup's media to 'Synced Content'
Summary: unable to update hostgroup's media to 'Synced Content'
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Host Group
Version: 6.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Mirek Długosz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 03:38 UTC by matt jia
Modified: 2019-12-03 12:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-12-03 12:54:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description matt jia 2018-05-04 03:38:10 UTC
Description of problem:

In Google Chrome, I can't update a hostgroup with 'Synced Content'  selected.


Version-Release number of selected component (if applicable):

6.3.1

How reproducible:

Easy

Steps to Reproduce:
1. edit a hostgroup with 'All media' selected
2. in the OS tab, change it to 'Synced Content' 
3. save it

Actual results:

Nothing is updated as 'All Media' is still selected. 

Expected results:

The hostgroup should be updated with 'Synced Content' seleted.

Additional info:

This doesn't happen on Firefox. Checking the db can see that both medium_id and kickstart_repository_id are not Nil. However, in this case, medium_id should be set Nil.

irb(main):033:0> pp hg
#<Hostgroup:0x0000000009c2c488
 id: 13,
 name: "test",
 created_at: Wed, 02 May 2018 05:09:33 UTC +00:00,
 updated_at: Fri, 04 May 2018 02:23:35 UTC +00:00,
 environment_id: nil,
 operatingsystem_id: 15,
 architecture_id: 1,
 medium_id: 11,
 ptable_id: 61,
 root_pass: "",
 puppet_ca_proxy_id: nil,
 use_image: nil,
 image_file: nil,
 ancestry: nil,
 vm_defaults: nil,
 subnet_id: nil,
 domain_id: nil,
 puppet_proxy_id: nil,
 title: "test",
 realm_id: nil,
 compute_profile_id: nil,
 content_source_id: 1,
 grub_pass: "",
 content_view_id: 1,
 lifecycle_environment_id: 1,
 lookup_value_matcher: "hostgroup=test",
 openscap_proxy_id: nil,
 kickstart_repository_id: 337,
 subnet6_id: nil,
 pxe_loader: "PXELinux BIOS">
=> #<Hostgroup id: 13, name: "test", created_at: "2018-05-02 05:09:33", updated_at: "2018-05-04 02:23:35", environment_id: nil, operatingsystem_id: 15, architecture_id: 1, medium_id: 11, ptable_id: 61, root_pass: "", puppet_ca_proxy_id: nil, use_image: nil, image_file: nil, ancestry: nil, vm_defaults: nil, subnet_id: nil, domain_id: nil, puppet_proxy_id: nil, title: "test", realm_id: nil, compute_profile_id: nil, content_source_id: 1, grub_pass: "", content_view_id: 1, lifecycle_environment_id: 1, lookup_value_matcher: "hostgroup=test", openscap_proxy_id: nil, kickstart_repository_id: 337, subnet6_id: nil, pxe_loader: "PXELinux BIOS">

Comment 1 matt jia 2018-05-04 03:39:31 UTC
>In Google Chrome, I can't update a hostgroup with 'Synced Content'  selected.

To be clear, I want to update the hostgroup with 'Synced Content'  selected. By default, it has 'All media' selected.

Comment 2 matt jia 2018-05-04 03:43:47 UTC
It seems like this we would also to fix this

https://bugzilla.redhat.com/show_bug.cgi?id=1511049

Comment 3 matt jia 2018-05-08 05:47:17 UTC
Moreover, cu is experiencing this issue with Firefox ESR 52.

Comment 4 Brad Buckingham 2018-05-15 15:48:52 UTC
Hi Matt,

Do you have an internal reproducer that we could access?

Comment 5 matt jia 2018-05-16 00:16:03 UTC
(In reply to Brad Buckingham from comment #4)
> Hi Matt,
> 
> Do you have an internal reproducer that we could access?

I don't have it for firefox(I can't reproduce it though), but you would be able to see this issue with any Satellite 6.3 on Google Chrome.

Comment 6 Brad Buckingham 2018-05-22 15:44:14 UTC
Matt,

Apologies, I was looking for access to the Satellite where this is being reproduced vs the client.  Is the server available?

Comment 11 Bryan Kearney 2019-11-04 14:34:21 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 12 Bryan Kearney 2019-12-03 12:54:02 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.