Bug 1574860 - Changing the journald.conf when installing or upgrading to OCP3.7
Summary: Changing the journald.conf when installing or upgrading to OCP3.7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.7.1
Hardware: All
OS: All
unspecified
medium
Target Milestone: ---
: ---
Assignee: Brenton Leanhardt
QA Contact: Xiaoli Tian
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 08:05 UTC by Andre Costa
Modified: 2019-04-18 15:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-18 15:00:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andre Costa 2018-05-04 08:05:17 UTC
Description of problem:
When installing or upgrading OCP 3.7 there's a role playbook which configures the /etc/systemd/journald.conf and restarts the systemd-journald.service. Changing the SystemMaxUse=8G causes the filesystem usage to increase and this may cause the atomic-openshift services to stop. 

Version-Release number of selected component (if applicable):
Openshift v3.7

How reproducible:
This seems to be hard-coded on the playbooks used by the installer

Expected results:
Customer would like to have the possibility to have variables to use on the inventory hosts file in order to setup the journald.conf
Without any option the solution now is to manually configure this file on OCP nodes.

Additional info:
https://github.com/openshift/openshift-ansible/issues/6465

Comment 3 Scott Dodson 2019-04-18 15:00:34 UTC
We cleaned up the ability to configure journald options in the follow bugs for 3.11 and 3.10.

https://bugzilla.redhat.com/show_bug.cgi?id=1667185
https://bugzilla.redhat.com/show_bug.cgi?id=1676905


Note You need to log in before you can comment on or make changes to this bug.