Bug 1574941 - Bluetooth speaker connects but cannot play audio
Summary: Bluetooth speaker connects but cannot play audio
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 28
Hardware: x86_64
OS: Linux
high
unspecified
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 11:49 UTC by Jim Downie
Modified: 2019-05-28 20:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-28 20:13:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Jim Downie 2018-05-04 11:49:44 UTC
Description of problem:

Laptop appears to connect to bluetooth speaker (Anker SoundCore 2). gnome-bluetooth and bluetoothctl both say there is an active connection, and the speaker appears in audio devices in gnome-settings, but the speaker does not play a confirmation sound upon connection, and no audio can be heard when the speaker is selected as the audio output. The speaker worked perfectly with F27 and also pairs fine with my phone.

Bluetooth/WiFi chip is an Intel Corporation Wireless 8265 / 8275

journalctl provides this output:

May 04 11:46:23 cenococcum systemd[1]: bluetooth.target: Unit not needed anymore. Stopping.
May 04 11:46:28 cenococcum bluetoothd[854]: Failed to set mode: Blocked through rfkill (0x12)
May 04 11:46:28 cenococcum bluetoothd[854]: Endpoint registered: sender=:1.79 path=/MediaEndpoint/A2DPSource
May 04 11:46:28 cenococcum bluetoothd[854]: Endpoint registered: sender=:1.79 path=/MediaEndpoint/A2DPSink
May 04 11:46:28 cenococcum bluetoothd[854]: Failed to set mode: Blocked through rfkill (0x12)
May 04 11:46:28 cenococcum bluetoothd[854]: Failed to set mode: Blocked through rfkill (0x12)
May 04 11:46:28 cenococcum bluetoothd[854]: Failed to set mode: Blocked through rfkill (0x12)
May 04 11:47:10 cenococcum bluetoothd[854]: Unable to get io data for Hands-Free Voice gateway: getpeername: Transport endpoint is not connected (107)
May 04 11:47:10 cenococcum dbus-daemon[869]: [system] Rejected send message, 1 matched rules; type="method_return", sender=":1.79" (uid=1000 pid=1857 comm="/usr/bin/pulseaudio --daemonize=no " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.4" (uid=0 pid=854 comm="/usr/libexec/bluetooth/bluetoothd " label="system_u:system_r:bluetooth_t:s0")

Version-Release number of selected component (if applicable):

bluetoothctl version 5.49
linux-firmware 20180402

How reproducible:

Always, either when pairing for the first time or when reconnecting to the speaker.

Steps to Reproduce:
1. Pair speaker with computer via gnome-bluetooth or bluetoothctl.
2. Once paired, play audio.
3.

Actual results:

Bluetooth speaker appears to be connected but no audio can be heard.

Expected results:

Bluetooth speaker should connect and be able to play audio.

Additional info:

Comment 1 Paolo Antinori 2018-05-06 12:10:57 UTC
Same issue here. happy to perform tests if asked.

Comment 2 Jim Downie 2018-05-13 18:45:43 UTC
I have been playing about with this a bit and it seems it might be an issue with PulseAudio. Running pacmd ls, I can get the PulseAudio index for the device:

    index: 1
	name: <bluez_card.08_EB_ED_99_58_41>
	driver: <module-bluez5-device.c>
	owner module: 25
	properties:
		device.description = "SoundCore 2"
		device.string = "08:EB:ED:99:58:41"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "speaker"
		bluez.path = "/org/bluez/hci0/dev_08_EB_ED_99_58_41"
		bluez.class = "0x240414"
		bluez.alias = "SoundCore 2"
		device.icon_name = "audio-speakers-bluetooth"

Then running `pacmd set-card-profile 1 a2dp_sink` forces the device into a2dp_sink mode, after which I can play sound through the device quite happily. This seems to be stable through both disconnecting and forgetting the device and re-pairing, though I haven't tried it after rebooting yet.

Comment 3 Ben Cotton 2019-05-02 21:47:33 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 4 Ben Cotton 2019-05-28 20:13:34 UTC
Fedora 28 changed to end-of-life (EOL) status on 2019-05-28. Fedora 28 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.