Bug 1575132 - openstack event list returns __init__() got an unexpected keyword argument 'username'
Summary: openstack event list returns __init__() got an unexpected keyword argument 'u...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-pankoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: z3
: 13.0 (Queens)
Assignee: Mehdi ABAAKOUK
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-04 20:26 UTC by Marius Cornea
Modified: 2018-11-14 01:15 UTC (History)
6 users (show)

Fixed In Version: python-pankoclient-0.4.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-14 01:14:53 UTC
Target Upstream Version:
lmarsh: needinfo-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1747718 0 None None None 2018-05-18 07:53:25 UTC
OpenStack gerrit 552930 0 None master: MERGED python-pankoclient: Make osc plugin work again (I1cd33feec81bafad6237ca72b9c2f410237898b4) 2018-08-30 17:28:33 UTC
OpenStack gerrit 552981 0 None master: MERGED python-pankoclient: Handle strings as response error_message (I9643303973edd992066ff013a9cec21be689ae84) 2018-08-30 17:28:26 UTC
OpenStack gerrit 575391 0 None stable/queens: MERGED python-pankoclient: Make osc plugin work again (I1cd33feec81bafad6237ca72b9c2f410237898b4) 2018-08-30 17:28:20 UTC
OpenStack gerrit 575392 0 None stable/queens: MERGED python-pankoclient: Handle strings as response error_message (I9643303973edd992066ff013a9cec21be689ae84) 2018-08-30 17:28:14 UTC
Red Hat Product Errata RHBA-2018:3615 0 None None None 2018-11-14 01:15:01 UTC

Description Marius Cornea 2018-05-04 20:26:10 UTC
Description of problem:
openstack event list returns __init__() got an unexpected keyword argument 'username'

Version-Release number of selected component (if applicable):
python2-pankoclient-0.4.0-1.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP13 undercloud + overcloud
2. On undercloud install python-pankoclient:
sudo yum install -y python-pankoclient
3. source overcloudrc
4. openstack event list


Actual results:
__init__() got an unexpected keyword argument 'username'

Expected results:
No errors

Additional info:

Comment 9 Sasha Smolyak 2018-11-01 11:55:09 UTC
1. Deploy OSP13 undercloud + overcloud
2. On undercloud install python-pankoclient:
sudo yum install -y python-pankoclient
3. source overcloudrc
4. openstack event list

Get a list of events. 
Verified

Comment 12 errata-xmlrpc 2018-11-14 01:14:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3615


Note You need to log in before you can comment on or make changes to this bug.