Bug 157516 - RFE: RT Limits for Pro-Audio
RFE: RT Limits for Pro-Audio
Status: CLOSED DUPLICATE of bug 157050
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 03:14 EDT by Rahul Sundaram
Modified: 2013-03-13 01:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 03:36:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2005-05-12 03:14:35 EDT
Description of problem:


Pro Audio people require a mechanism to provide preferential scheduling to audio
applications. RT limits patch has been merged upstream. More information
available here

http://www.steamballoon.com/wiki/Rlimits 


Expected results:

Provide a mechanism for audio professionals to use this capability in a non
intrusive secure way

Additional info:

Distributions like Agnula (http://www.agnula.org/) and repos like Planet CCRMA
(http://ccrma.stanford.edu/planetccrma/software/) depend on similar functionality.
Comment 1 Tomas Mraz 2005-05-12 03:36:09 EDT

*** This bug has been marked as a duplicate of 157050 ***
Comment 2 Fernando Lopez-Lezcano 2005-05-12 14:15:12 EDT
I already did a release of 2.6.12-rc4 low latency kernels (they include the
realtme preempt patches from Ingo Molnar) at Planet CCRMA and a suitably patched
pam that enables access to realtime scheduling and memory locking "out of the
box", see the announcement here:

http://ccrma-mail.stanford.edu/pipermail/planetccrma/2005-May/009139.html

Before switching to the rlimits patch I was relying on the realtime lsm kernel
module by Jack O'Quin to get the same results. 

The source package for the modified pam is here:
http://ccrma.stanford.edu/planetccrma/mirror/all/linux/SRPMS/pam-0.77-66.2.3.src.rpm
and the kernel is here:
http://ccrma.stanford.edu/planetccrma/mirror/all/linux/SRPMS/kernel-2.6.11-0.10.rdt.src.rpm

The patches to pam not only make it aware of the new limits options (that was
part of the packages released in the steambaloon.com wiki referenced above) but
also adds a bit of documentation to /etc/security/limits.conf and enables access
to everyone by default (which is probably not what Fedora would do, in my case I
need to install the whole thing and be ready to start apps that use realtime
scheduling with no user configuration of /etc files - the Jack Audio Connection
Kit audio server is the best example, many applications depend on it and it has
to have access to realtime scheduling and memory locking to be of any use). 

BTW, the Fedora project should consider adding an "audio" group to the stock
install, that would make configuration and restriction of permissions much easier. 

Note You need to log in before you can comment on or make changes to this bug.