Bug 157528 - clamav issues
clamav issues
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 07:57 EDT by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-12 08:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2005-05-12 07:57:16 EDT
0. Please rename clamd-wrapper init script to clamd (same as upstream rpms and
same as other servers, e.g. httpd is named httpd not httpd-wrapper).

1. Installing clamav-server clamav-update with yum doesn't also pull clamav. Is
this intended?

2. After installing those:
# service clamd-wrapper start
clamd-wrapper: unrecognized service

Please run chkconfig --add in POST-install script (and --del on PRE-uninstall)

3. freshclam requires manual changes to enable it. I know it's because of not
setting same hour everywhere in order to spread the load.
Upstream clamav rpms enable freshclam as a daemon, can't the same setup be used?
If not, then generate some random hour - minute on install to put in cron file,
so it works out of the box.

Thanks!
Comment 1 Enrico Scholz 2005-05-12 08:41:38 EDT
| 0. Please rename clamd-wrapper init script to clamd (same as upstream
|    rpms and same as other servers, e.g. httpd is named httpd not
|    httpd-wrapper).

A common clamd daemon is not possible and such a daemon is not useful
in most cases.

E.g. see http://bugzilla.fedora.us/show_bug.cgi?id=268#c8 for
explainations.



| 1. Installing clamav-server clamav-update with yum doesn't also pull
|    clamav. Is this intended?

Yes; client part is not needed for the server.


| 2. After installing those:
| # service clamd-wrapper start
| clamd-wrapper: unrecognized service
| 
|    Please run chkconfig --add in POST-install script (and --del on
|    PRE-uninstall)

Not possible; clamd-wrapper is a wrapper but not a service.


| 3. freshclam requires manual changes to enable it. I know it's because
|    of not setting same hour everywhere in order to spread the load.
| 
|    Upstream clamav rpms enable freshclam as a daemon, can't the same
|    setup be used? If not, then generate some random hour - minute on
|    install to put in cron file, so it works out of the box.

Running as a daemon is bad because database changes can not be
propagated. For details, please see
http://bugzilla.fedora.us/show_bug.cgi?id=1715#c43 point 4.



For more details about the clamav packaging please read the tickets at
the fedora.us bugzilla. They explain all of the issues above.


http://bugzilla.fedora.us/buglist.cgi?field0-0-0=short_desc&type0-0-0=substring&value0-0-0=clamav%20

Note You need to log in before you can comment on or make changes to this bug.