Bug 1575309 - the '--set-upstream' option is no longer supported
Summary: the '--set-upstream' option is no longer supported
Keywords:
Status: CLOSED DUPLICATE of bug 1564233
Alias: None
Product: Fedora
Classification: Fedora
Component: git-review
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 21:36 UTC by Nicolas Hicher
Modified: 2018-05-07 04:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 04:44:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Nicolas Hicher 2018-05-05 21:36:10 UTC
When using 'git review -d $review' an error message is printed:


git review -d 12087
Downloading refs/changes/87/12087/1 from gerrit
Cannot set upstream to remote branch
The following command failed with exit code 128
    "git branch --set-upstream review/nicolas_hicher/12087 gerrit/master"                                                          
-----------------------
fatal: the '--set-upstream' option is no longer supported. Please use '--track' or '--set-upstream-to' instead.                    
-----------------------


Version-Release number of selected component (if applicable):

git-review-1.25.0-9.fc28.noarch


You can reproduce the bug using the following command

$ git clone https://softwarefactory-project.io/r/software-factory/sf-docs
$ git review -d 12087


Actual results:
Downloading refs/changes/87/12087/1 from gerrit
Cannot set upstream to remote branch
The following command failed with exit code 128
    "git branch --set-upstream review/nicolas_hicher/12087 gerrit/master"                                                          
-----------------------
fatal: the '--set-upstream' option is no longer supported. Please use '--track' or '--set-upstream-to' instead.

Expected results:
No fatal error when using git review

Additional info:

A patch was merged upstream https://review.openstack.org/#/c/517831/, is present on git-review 1.26

Thanks

Comment 1 Ian Wienand 2018-05-07 04:44:44 UTC

*** This bug has been marked as a duplicate of bug 1564233 ***


Note You need to log in before you can comment on or make changes to this bug.