Bug 1575313 - Libreoffice crashes on start because it cannot find libicudata.so.57
Summary: Libreoffice crashes on start because it cannot find libicudata.so.57
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-05 22:29 UTC by Marco Guazzone
Modified: 2018-05-06 13:03 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-06 13:03:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Marco Guazzone 2018-05-05 22:29:23 UTC
Description of problem:

Unable to start LibreOffice. When I run one of the LibreOffice application I get the following error:

/usr/lib64/libreoffice/program/soffice.bin: error while loading shared libraries: libicudata.so.57: cannot open shared object file: No such file or directory

Version-Release number of selected component (if applicable):
6.0.3.2-5.fc28

How reproducible:
Just run LibreOffice (e.g. oocalc) inside your desktop environment.

Steps to Reproduce:
1. Log in your desktop environment
2. Run "oocalc"
3.

Actual results:

The application crashes on start with the following error:

/usr/lib64/libreoffice/program/soffice.bin: error while loading shared 
libraries: libicudata.so.57: cannot open shared object file: No such file or directory

Expected results:

The application should start and run without error.

Additional info:

My system if Fedora 28 x86_64.
I've also tried:
1. to run LibreOffice both inside XFCE (my primary desktop environment) and inside GNOME Shell, and
2. to downgrade to LibreOffice v. 6.0.3.2-1.fc28
but without success.

Comment 1 Marco Guazzone 2018-05-06 12:24:19 UTC
For those like me that need to use Libreoffice urgently: flatpak is your friend.

1. Install flatpak (it should already be shipped with Fedora):
 $ sudo dnf install flatpak

2. Install the Flathub repo (the option '--user' just install in your home dir so that you don't need root permissions):
 $ flatpak remote-add --user --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

3. Install Libreoffice from flathub:
 $ flatpak install --user flathub org.libreoffice.LibreOffice

4. Enjoy your sandboxed LibreOffice installation:
 $ flatpak run org.libreoffice.LibreOffice

Comment 2 Marco Guazzone 2018-05-06 13:03:37 UTC
Oops, I've just realized that this problem is due to a local installation of Boost libraries (that I've compiled before upgrading from Fedora 27 to 28 and installed in my home directory).

By erasing this installation LibreOffice works without problems.

Sorry for this false alarm. I close this bug report.


Note You need to log in before you can comment on or make changes to this bug.