Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1575320 - blivet.errors.LUKSError: luks device not configured
Summary: blivet.errors.LUKSError: luks device not configured
Keywords:
Status: CLOSED DUPLICATE of bug 1624617
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Blivet Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:25a53a23375f5d326cf69115d5d...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-06 00:23 UTC by John F Sullivan
Modified: 2018-09-27 09:20 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-27 09:20:02 UTC
Type: ---


Attachments (Terms of Use)
File: anaconda-tb (4.66 MB, text/plain)
2018-05-06 00:23 UTC, John F Sullivan
no flags Details
File: anaconda.log (337.72 KB, text/plain)
2018-05-06 00:23 UTC, John F Sullivan
no flags Details
File: blivet-gui-utils.log (8.16 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: dbus.log (6.20 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: environ (733 bytes, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: journalctl (1.70 MB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: lsblk_output (1.87 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: lvm.log (668.68 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: nmcli_dev_list (4.95 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: os_info (623 bytes, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: program.log (309.37 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: storage.log (1.40 MB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details
File: ifcfg.log (10.27 KB, text/plain)
2018-05-06 00:24 UTC, John F Sullivan
no flags Details

Description John F Sullivan 2018-05-06 00:23:41 UTC
Description of problem:
Attempting to install fedora with the following storage configuration:
/dev/sda1: 1GB EFI partition
/dev/sda2: 5GB ext4 boot partition
/dev/sda3 LUKS-encrypted LVM PV

LVs:
f28-root: btrfs mount as /
f28-tmp: btrfs mount as /tmp
f28-var: btrfs mount as /var
f28-var-log: btrfs mount as /var/log
f28-var-log-audit: btrfs mount as /var/log/audit
f28-var-tmp: btrfs mount as /tmp
home: btrfs mount as /home
archive: btrfs mount as /mnt/archive
swap: swap device

Version-Release number of selected component:
anaconda-core-28.22.10-1.fc28.x86_64

The following was filed automatically by anaconda:
anaconda 28.22.10 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.6/site-packages/blivet/formats/luks.py", line 217, in _pre_setup
    raise LUKSError("luks device not configured")
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 603, in setup
    if not self._pre_setup(**kwargs):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 515, in setup_parents
    _format.setup()
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 372, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 383, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 507, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 372, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 233, in _pre_setup
    return StorageDevice._pre_setup(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 383, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/device.py", line 211, in setup_parents
    parent.setup(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1922, in setup_parents
    Device.setup_parents(self, orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 372, in _pre_setup
    self.setup_parents(orig=orig)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 882, in _pre_setup
    if not super(LVMLogicalVolumeBase, self)._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/storage.py", line 383, in setup
    if not self._pre_setup(orig=orig):
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1926, in setup
    return DMDevice.setup(self, orig)
  File "/usr/lib/python3.6/site-packages/blivet/devices/lvm.py", line 1829, in decorated
    return meth(self, *args, **kwargs)  # pylint: disable=not-callable
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/deviceaction.py", line 704, in execute
    self.device.setup(orig=True)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 327, in process
    action.execute(callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/actionlist.py", line 48, in wrapped_func
    return func(obj, *args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/blivet.py", line 135, in do_it
    self.devicetree.actions.process(callbacks=callbacks, devices=self.devices)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/storage/osinstall.py", line 1219, in do_it
    super().do_it(callbacks=callbacks)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/storage/osinstall.py", line 2131, in turn_on_filesystems
    storage.do_it(callbacks)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 361, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 291, in run
    threading.Thread.run(self)
blivet.errors.LUKSError: luks device not configured

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-28-1-1 rd.live.image rd.live.check quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.16.3-301.fc28.x86_64
other involved packages: python3-blivet-3.0.0-0.6.1.b1.fc28.noarch, python3-libs-3.6.5-1.fc28.x86_64
product:        Fedora
release:        Fedora release 28 (Twenty Eight)
type:           anaconda
version:        28

Comment 1 John F Sullivan 2018-05-06 00:23:57 UTC
Created attachment 1432164 [details]
File: anaconda-tb

Comment 2 John F Sullivan 2018-05-06 00:23:59 UTC
Created attachment 1432165 [details]
File: anaconda.log

Comment 3 John F Sullivan 2018-05-06 00:24:00 UTC
Created attachment 1432166 [details]
File: blivet-gui-utils.log

Comment 4 John F Sullivan 2018-05-06 00:24:02 UTC
Created attachment 1432167 [details]
File: dbus.log

Comment 5 John F Sullivan 2018-05-06 00:24:03 UTC
Created attachment 1432168 [details]
File: environ

Comment 6 John F Sullivan 2018-05-06 00:24:08 UTC
Created attachment 1432169 [details]
File: journalctl

Comment 7 John F Sullivan 2018-05-06 00:24:09 UTC
Created attachment 1432170 [details]
File: lsblk_output

Comment 8 John F Sullivan 2018-05-06 00:24:11 UTC
Created attachment 1432171 [details]
File: lvm.log

Comment 9 John F Sullivan 2018-05-06 00:24:13 UTC
Created attachment 1432172 [details]
File: nmcli_dev_list

Comment 10 John F Sullivan 2018-05-06 00:24:14 UTC
Created attachment 1432173 [details]
File: os_info

Comment 11 John F Sullivan 2018-05-06 00:24:15 UTC
Created attachment 1432174 [details]
File: program.log

Comment 12 John F Sullivan 2018-05-06 00:24:20 UTC
Created attachment 1432175 [details]
File: storage.log

Comment 13 John F Sullivan 2018-05-06 00:24:21 UTC
Created attachment 1432176 [details]
File: ifcfg.log

Comment 14 John F Sullivan 2018-05-06 11:48:11 UTC
This issue occurred during characterization of 1575323.

I installed from the Fedora 28 Live Workstation image and encountered the error described by 1575323, then re-executed the installer without rebooting the USB image.  Whereas the first attempt asked me for the LUKS passphrase to decrypt the LVM physical volume, the second attempt did not.  I proceeded under the assumption that I would not need to unlock the LUKS volume again.

Also please note that after rebooting the Fedora 28 Live Workstation image, I did not encounter this "luks device not configured" error.

Comment 15 Jiri Konecny 2018-05-07 07:20:03 UTC
Based on the traceback this is storage related issue. Changing component to our storage library.

Comment 16 Vojtech Trefny 2018-09-27 09:20:02 UTC

*** This bug has been marked as a duplicate of bug 1624617 ***


Note You need to log in before you can comment on or make changes to this bug.