Bug 1575518 - mc archive extraction fails with: _moduleraw not a function
Summary: mc archive extraction fails with: _moduleraw not a function
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mc
Version: 28
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 07:48 UTC by Andrea
Modified: 2018-05-07 18:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 15:23:54 UTC
Type: Bug


Attachments (Terms of Use)
Error message screenshot (9.94 KB, image/png)
2018-05-07 07:48 UTC, Andrea
no flags Details

Description Andrea 2018-05-07 07:48:10 UTC
Created attachment 1432519 [details]
Error message screenshot

Description of problem:

when I try to extract (i.e. F5=copy) files from a .zip archive with mc I get this error message:

/usr/share/Modules/init/bash: line 58: export: _moduleraw: not a function

Version-Release number of selected component (if applicable):

Fedora 28 fully updated as of 6 Mat 2018
mc: 4.1.19
bash: 4.4.19(1)

File seems to be extracted. the right panel is not updated, but the file is there.

F5 from a non .zip works.

How reproducible:

Always, but if I immediately extract again the same file it does not err. A different file, yes, same message.

Steps to Reproduce:
1. start mc
2. select a .zip on the left panel
3. F5 to copy to the right panel

Actual results:

error message as described, right panel not updated, but file IS copied

Expected results:

no message, right panels updated

Comment 1 Tomasz Kłoczko 2018-05-07 11:10:05 UTC
$ rpm -qf /usr/share/Modules/init/bash
error: file /usr/share/Modules/init/bash: No such file or directory
$ grep -r Module /usr/libexec/mc/*
$
$ strings /usr/bin/mc| grep Module
$

This script is not part of the mc and whatever is wrong here is not part of the mc.
mc can copy multiple not only .zip file s but any other files.
What you've described is just normal/regular copy of any file (not only the .zip file).

Comment 2 Andrea 2018-05-07 14:19:39 UTC
You might be right, but this is what I have in my system.

I have upgraded the last 3-4 Fedoras, so it might be something that has not completed properly in the upgrades.

I will try to see where it comes from.

Comment 3 Andrea 2018-05-07 14:25:15 UTC
The file is not part of mc, but it belongs to environment-modules

andrea@bomba:/usr/share/Modules/init$ rpm -qf /usr/share/Modules/init/bash
environment-modules-4.1.2-1.fc28.x86_64

In any case it is either a problem with one of the 2 packages or the way they work together.

If you believe it is not mc, it should be reassigned, but it is still a bug I can trigger with mc.

Comment 4 Tomasz Kłoczko 2018-05-07 14:54:19 UTC
Problem is that with your description of the issue it is just normal copy of the file.
I don't want to say that there is no issues with mc vfs but on quick test with some zip file I was not able to reproduce any issues and definitely packaged mc is not using  /usr/share/Modules/init/bash .. only this and nothing more :)

Comment 5 Andrea 2018-05-07 15:14:35 UTC
I have tried in a different user with almost a default set up and it does not happen.

It happens not just when copying files from a .zip but when browsing archives.

e.g. when I look into bash-4.4.19-2.fc28.x86_64.rpm

mc must be triggering that script directly or indirectly via bash or other things.

I guess I will open a bug for that package which already had something similar

https://bugzilla.redhat.com/show_bug.cgi?id=1565697

would you know what bash command is used by mc to extract zip files?
I would like to reproduce it in a smaller setup to find what the issue is.

Comment 6 Andrea 2018-05-07 15:20:19 UTC
here is another one

https://bugzilla.redhat.com/show_bug.cgi?id=1575479

Comment 7 Tomasz Kłoczko 2018-05-07 15:23:54 UTC
This is not bug in mc.

Comment 8 Andrea 2018-05-07 18:03:17 UTC
For the record if anybody ever comes here, I reset my .bashrc (which could have been up to 15Y old) and solved it.


Note You need to log in before you can comment on or make changes to this bug.