This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 157552 - X server crashing - drm:i830_wait_ring ERRORS
X server crashing - drm:i830_wait_ring ERRORS
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 13:16 EDT by David Milburn
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attaching messages file from Comment #9 (833.37 KB, application/octet-stream)
2006-07-26 18:18 EDT, David Milburn
no flags Details
Attaching messages file from Comment #9 (833.37 KB, text/plain)
2006-07-26 18:21 EDT, David Milburn
no flags Details
Attaching messages file from Comment #3 (833.37 KB, text/plain)
2006-07-26 18:29 EDT, David Milburn
no flags Details

  None (edit)
Description David Milburn 2005-05-12 13:16:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Customer is seeing X Server crash on RHEL3 U4 on the 82865G chipset.

kernel: [drm:i830_wait_ring] *ERROR* space: 130880 wanted 131064
kernel: [drm:i830_wait_ring] *ERROR* lockup
kernel: [drm:i830_wait_ring] *ERROR* space: 129888 wanted 131064
kernel: [drm:i830_wait_ring] *ERROR* lockup
kernel: [drm:i830_wait_ring] *ERROR* space: 129840 wanted 131064
kernel: [drm:i830_wait_ring] *ERROR* lockup

Customer states this occurs when switching between Linux sessions
and HP-UX sessions.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.EL

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.Switch between Linux sessions and HP-UX sessions.
2.
3.
  

Actual Results:  X server crashed

Expected Results:  X server should not crash

Additional info:
Comment 1 Don Howard 2005-05-18 14:11:54 EDT
Hi David

Can you please test the kernels at http://people.redhat.com/dhoward/bz138534/
and let me know if they correct the crash?
Comment 4 Maximilian 2006-01-05 13:22:08 EST
I experience the same problem with Fedora Core 1
(but it seems to persist still in FC4)

I reproduce this bug whenever I switch from the X display to one of
the text consoles (Using Ctrl-Alt-F1 or so).

According to google & co, many people have this problem.
Why is there no information here in this place ?

I found on the web "the i830 driver is depreciated, use the i915 instead"
but I did not find any way to get it.
Could somebody give me a hint where I could just download the i915.o file ?
(This could be so simple, just a few bytes to copy on my harddisk ;
but probably some guru will reply that one should modify some config files and
recompile the sources ; completely useless to 99% of the users (while the
remaining 1% who knew how to do this don't have this problem).

And: why don't "they" fix this bug in the i830 driver ?
 
Thanks in advance!
Comment 5 Don Howard 2006-02-17 17:03:00 EST
From the XFree86 changelog:

XFree86 4.5.99.13 (8 October 2005)
 ...
 151. Fix lockup when suspend and resume when playing video on the i830.
      So we shutdown the overlay on LeaveVT (Alan Hourihane).


The kernel drm error message appears to be timing-related. This is starting to
look like an X server issue, rather than kernel.
Comment 20 RHEL Product and Program Management 2007-10-19 15:02:28 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.