Bug 1575586 - Active snapshot disks appears when creating VM template from snapshot instead of the snapshot disks
Summary: Active snapshot disks appears when creating VM template from snapshot instead...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ovirt-4.2.7
: ---
Assignee: Eyal Shenitzky
QA Contact: Avihai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 11:40 UTC by Eyal Shenitzky
Modified: 2018-11-02 14:33 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.2.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-02 14:33:35 UTC
oVirt Team: Storage
rule-engine: ovirt-4.2+
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 91091 master MERGED webadmin: show snapshot disks while creating a template from a snapshot 2018-05-17 08:51:57 UTC
oVirt gerrit 94037 ovirt-engine-4.2 MERGED webadmin: show snapshot disks while creating a template from a snapshot 2018-08-30 10:05:30 UTC

Description Eyal Shenitzky 2018-05-07 11:40:50 UTC
Description of problem:

When creating a VM template from one of the VM snapshots using the UI, the disks that appear in the pop-up windows belongs to the active snapshot state, for e.g:

VM with a snapshot that contains only one disk and the active VM snapshot have 2 disks.
when trying to create a VM template from the snapshot, two disks appear in the UI window (the disks that belongs to the active snapshot) instead of one disk only.

Version-Release number of selected component (if applicable):
master 4.3.0 - from the commit 56af10f17ad1ed06611c99abec486fe03e91dd3e

How reproducible:
100%

Steps to Reproduce:
1. Create a VM with one disk
2. Create a snapshot to the VM from step 1
3. Add another disk to the VM from step 1
4. Try to create a VM template from the snapshot that created in step 2 using the UI

Actual results:
The VM template creation widow presents the disks of the active VM

Expected results:
Only the disks that belong to the snapshot should appear in the window.

Additional info:

Comment 1 Eyal Shenitzky 2018-08-30 09:03:00 UTC
Occurs also in 4.2 version.

Comment 2 Avihai 2018-09-13 09:33:22 UTC
Verified in upstream build 4.3.0-0.0.master.20180815091554.gitd5455ea.el7.

Only the disks that belong to the snapshot we are creating a template from appear in the UI window as expected.

Comment 3 Raz Tamir 2018-09-13 10:30:08 UTC
QE verification bot: the bug was verified upstream

Comment 4 Avihai 2018-09-13 11:03:54 UTC
Needs to be verified in 4.2 upstream as well

Comment 5 Avihai 2018-09-16 15:11:02 UTC
Verified also in 4.2 upstream 4.2.6.5-0.0.master.20180914152430.gitb8a2050.el7

Comment 6 Raz Tamir 2018-09-16 15:30:09 UTC
QE verification bot: the bug was verified upstream

Comment 7 Sandro Bonazzola 2018-11-02 14:33:35 UTC
This bugzilla is included in oVirt 4.2.7 release, published on November 2nd 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.7 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.