Bug 157562 - gv must be resurrected
gv must be resurrected
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gv (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-12 14:24 EDT by Jonathan S. Shapiro
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 21:01:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan S. Shapiro 2005-05-12 14:24:22 EDT
The 'gv' package appears to have been dropped from the FC4 tree. This is not
okay, because no functional alternative has been incorporated.

ggv, which appears to have morphed into evince, lacks an absolutely critical
feature for document authors: the ability to "watch" a postscript file and
reload when the postscript file has been modified.
Comment 1 Jonathan S. Shapiro 2005-05-12 14:37:52 EDT
I pulled the SRPMS from FC3 to see if it would rebuild cleanly and run correctly.

The only edit required was to change the Copyright: tag in the SPEC file to a
License: tag. The legacy Copyright: tag is no longer supported by rpmbuild.
Comment 2 Marius Andreiana 2005-05-13 01:31:08 EDT
It doesn't sound "critical" for me... Would you please file an upstream request
(bugzilla.gnome.org) on evince about this? 
Comment 3 Jonathan S. Shapiro 2005-05-13 09:40:35 EDT
You might notice that I didn't file a high-priority bug report...

But let me explain why I think it is important. I think that you and I are
making different use-case assumptions.

evince is a much better tool for the general end user who is not engaged in
document production. It is essentially "option free" and therefore relatively
idiot proof. In my opinion, it makes absolutely crappy use of screen real
estate, but most end users won't care -- they probably feel that visual
consistency with other viewers is more important, which is fine.

evince is not effective for document authors, because it doesn't fit into the
document author's equivalent to the "edit compile debug" loop. It lacks the
control options on things like bounding box handling, antialiasing, and change
watching that gv had, but the most critical thing is --watch, (which is also the
reason I never used ggv).

Why?

As an author, I sit with two things on my screen: gv on one side set to watch,
and emacs on the other. I edit my latex document, run 'make' to generate a new
PS file, and gv automatically reloads as needed. This lets me get near-wysiwyg
in an authoring environment that can still be used during a build process. Also,
in the only authoring environment that provides really high-quality formatting.
I can't use things like lyx, because they don't provide sufficiently fine-grain
macro support. I can't use things like OpenOffice because (a) the range of
output types is insufficient and the template model is wrong for production
purposes, and (b) there is no command line formatting capability that does not
involve an interactive UI.

So: the feature set of 'gv' probably isn't relevant to the end user, but it is
nearly as important to a high-quality document author as "make" probably is to you.

For this reason, I really want to see it back in the release. When evince
provides equivalent control, by all means drop gv. But I have to say that if
evince is targeted at general end users, adding this kind of feature load is
precisely the wrong thing to do to evince...
Comment 4 Marius Andreiana 2005-05-13 11:52:21 EDT
I see yor point now and I agree with it.
tetex is kept in Fedora Core because documentation writers (including Red Hat's)
use it. For the same reason and based on above comment, I also sustain adding gv
back to Core .

However, I still think the --watch feature should be requested in
bugzilla.gnome.org. Please list there the link to this bug and let the evince
author decide if it's too much feature load. As it's a command line option, most
users won't notice it.
Comment 5 Jeremy Katz 2005-05-18 21:01:20 EDT
gv isn't going to be added back to Core.  If you're interested in maintaining it
in Fedora Extras, please see http://fedoraproject.org/wiki/Extras for
information on adding and maintaining packages in Fedora Extras

Note You need to log in before you can comment on or make changes to this bug.