Bug 1575621 - Unable to launch Firstboot screen on rhel6.10 snapshot2.0 compose
Summary: Unable to launch Firstboot screen on rhel6.10 snapshot2.0 compose
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firstboot
Version: 6.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kolman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1488032
TreeView+ depends on / blocked
 
Reported: 2018-05-07 12:56 UTC by Rehana
Modified: 2018-05-11 06:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-11 06:44:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rehana 2018-05-07 12:56:42 UTC
Description of problem:
Observed that "Firstboot" screens didnt appear after the "reboot" post installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install rhel6.10 compose, observed that Firstboot screen didnot appear after initial reboot
2.Also, Unable to run firstboot from terminal
3.No Firstboot file in /etc/sysconfig

[root@dhcp148-249 sysconfig]# rpm -qa --whatprovides firstboot
kexec-tools-2.0.0-310.el6.x86_64
[root@dhcp148-249 sysconfig]# 
[root@dhcp148-249 sysconfig]# ls | grep first*


Actual results:
No Firstboot screens

Expected results:
Firstboot screen should launch

Additional info:

Comment 2 Rehana 2018-05-07 15:59:07 UTC
Observed that Firstboot screens appear on "workstation"(snapshot2) variant machine . And screens fails to launch on "Server" variant. 

Marking it as regression

Comment 4 Martin Kolman 2018-05-10 11:32:01 UTC
(In reply to Rehana from comment #2)
> Observed that Firstboot screens appear on "workstation"(snapshot2) variant
> machine . And screens fails to launch on "Server" variant. 
> 
> Marking it as regression

Could you check with snapshot 2+ Server variant as well ? This bug really seems very similar to bug 1576371, which was caused by bug 1573181. 1573181 should be fixed be fixed from snapshot 2 onwards.

Comment 6 Rehana 2018-05-11 06:44:15 UTC
Changing the install option to "Desktop" during deployment solves the issue. Earlier deployment was done with "Basic server" with customize software selection options 'Desktop' and "general purpose desktop" enabled. Apologies for the confusion.

Closing the bug with "Works for me"


Note You need to log in before you can comment on or make changes to this bug.