Bug 1575656 - service-level command reports confusing delete action
Summary: service-level command reports confusing delete action
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 14:40 UTC by Aaron Weitekamp
Modified: 2018-05-17 14:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-17 14:17:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Aaron Weitekamp 2018-05-07 14:40:40 UTC
Description of problem:
I want to know the service level of my subscription but the service-level command with or without options reports deleting a unit UUID. It's confusing and troubling that a status command would be deleting something.

Version-Release number of selected component (if applicable):
subscription-manager-1.20.11-1.el7_5.x86_64

How reproducible:
unclear

Steps to Reproduce:
1. subscribe system
2. subscription-manager service-level [any_option]

Actual results:
returns "Unit 650af139-7e61-43a2-b3c0-50e26818ce09 has been deleted"

Expected results:
- Display information about service level
- "do no harm" (this command should be non-destructive)

Additional info:

Comment 2 John Sefler 2018-05-07 14:54:34 UTC
Aaron...  The "subscription-manager service-level" is not deleting anything.  It is reporting to you that your registered system (Unit 650af139-7e61-43a2-b3c0-50e26818ce09z) has been deleted by some other perpetrator.  The message is coming from the entitlement server.  Most likely, someone who has access to the customer portal with the same credentials that you used to register your system, selected your registered unit and deleted it.

To re-register your system using subscription-manager, I suggest...

1. subscription-manager clean    <=== this will remove the orphaned consumer cert from your system

2. subscription-manager register   <=== with the same options and credentials that you used last time you registered.

Comment 3 Kevin Howell 2018-05-17 14:17:03 UTC
Not a bug per comment 2.

Comment 4 Aaron Weitekamp 2018-05-17 14:43:47 UTC
(In reply to John Sefler from comment #2)
> Aaron...  The "subscription-manager service-level" is not deleting anything.
> It is reporting to you that your registered system (Unit
> 650af139-7e61-43a2-b3c0-50e26818ce09z) has been deleted by some other
> perpetrator.  The message is coming from the entitlement server.  Most
> likely, someone who has access to the customer portal with the same
> credentials that you used to register your system, selected your registered
> unit and deleted it.
> 

That's a great explanation--thank you. Unfortunately the error does not communicate that. What would be much more helpful is something like...

"The registered system (Unit ID 650af139-7e61-43a2-b3c0-50e26818ce09z) has been deleted from the server. Run 'subscription-manager clean' to remove the orphaned consumer certificate from the system, then re-register."


Note You need to log in before you can comment on or make changes to this bug.