Bug 1575675 - test_snapshot_pattern tempest test fails in most of the deployments
Summary: test_snapshot_pattern tempest test fails in most of the deployments
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: lpeer
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 15:13 UTC by Waldemar Znoinski
Modified: 2018-10-14 09:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-08 12:41:47 UTC
Target Upstream Version:


Attachments (Terms of Use)
tempest test results showing the issue (1.58 MB, text/html)
2018-05-07 15:13 UTC, Waldemar Znoinski
no flags Details

Description Waldemar Znoinski 2018-05-07 15:13:06 UTC
Created attachment 1432671 [details]
tempest test results showing the issue

Description of problem:
"Connection to the 10.0.0.216 via SSH timed out." while running:
tempest.scenario.test_snapshot_pattern.TestSnapshotPattern.test_snapshot_pattern[compute,id-608e604b-1d63-4a82-8e3e-91bc665c90b4,image,network,slow] (from opendaylight_osp13)



Version-Release number of selected component (if applicable):
osp13, opendaylight-8.0.0-9 RPM

How reproducible:
100% of the time in non-ha job
80% of the time in HA job

Steps to Reproduce:
1. deploy OSP13 with ODL
2. run the above tempest test as part of CI job (ostestr --concurrency 1 --regex tempest.scenario)
3.

Actual results:
test fails

Expected results:
test pass

Additional info:
test results attached

Comment 2 Waldemar Znoinski 2018-05-08 12:41:47 UTC
upstream OpenStack CI does _not_ run 'slow' tests [0], which test_snapshot_pattern is part of [1], in any of the nova, neutron or other main projects

because of the above it's impossible to say whether we should see this test passing or not in OpenDaylight deployments


[0] https://github.com/openstack/tempest/blob/master/tox.ini#L74-L84
[1] https://github.com/openstack/tempest/blob/master/tempest/scenario/test_snapshot_pattern.py#L44


Note You need to log in before you can comment on or make changes to this bug.