Bug 1575935 - Orchestration Service reconfigure failure
Summary: Orchestration Service reconfigure failure
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Bill Wei
QA Contact: Dave Johnson
URL:
Whiteboard: service:reconfigure
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 10:35 UTC by Leo Khomenko
Modified: 2018-06-19 13:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-18 22:10:27 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:
lkhomenk: automate_bug+


Attachments (Terms of Use)
ec2_orchestration_stack_service_reconfigure (22.15 KB, image/png)
2018-05-08 10:35 UTC, Leo Khomenko
no flags Details

Description Leo Khomenko 2018-05-08 10:35:59 UTC
Created attachment 1433123 [details]
ec2_orchestration_stack_service_reconfigure

Description of problem: Service created from EC2/Azure Orchestration template can't be reconfigured. part of options are not available for editing but required. check screenshot - stack_name/timeout/tenant/on_failure are not editable


Version-Release number of selected component (if applicable): 5.9.2.4.20180501195858_35dc609


How reproducible: 100%


Steps to Reproduce:
1. Create simple ec2/azure orchestration template
2. Order service from such template
3. Open details of service ordered in 2
4. Configuration - Reconfigure this service
5. Update any values
6. Submit

Actual results: Unable to submit because unable to fill/update required fields


Expected results: all fields should be editable


Additional info: 1)Not enough documentation on what should happen next - will it update existing Stack(ec2)/Deployment(azure)?
2) Are orchestration services supposed to be reconfigured?

Comment 2 Bill Wei 2018-05-08 20:28:31 UTC
Service dialog you used is auto generated from a template. It serves as a sample. User has freedom to edit it (enable, disable, hide, remove fields). You can also create your own dialog.

You can edit the dialog to make the fields that you mentioned reconfigurable. Stack name should not be changed.

This is NOT a bug.


Note You need to log in before you can comment on or make changes to this bug.