Bug 157599 - Several problems with dragging link to desktop
Summary: Several problems with dragging link to desktop
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard: FF3RawhideClose
Keywords:
: 200398 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-05-13 01:53 UTC by David Zeuthen
Modified: 2018-04-11 17:13 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 16:47:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 347673 None None None Never

Description David Zeuthen 2005-05-13 01:53:16 UTC
Description of problem:

Firefox now supports dragging an icon representing a link (from either the URL
entry bar or toolbar) to the desktop which is a useful feature (I used this a
lot on Windows). However, there are several problems with how this works in a
typical GNOME desktop from Rawhide.

First, when initiating DND without modifiers, the user gets a mouse pointer with
a question mark. When releasing on the desktop, a window appears but
focus-stealing-prevention results in this window not being shown. See bug 156710
 (especially the associated links) for details on how to deal with
focus-stealing-prevention.

Second, as a GNOME user, I expect a popup menu instead of a modal dialog (much
like when dragging files around using Nautilus).

Third, I'm not sure it makes sense to do anything but produce a link on the
desktop - giving the user the opportunity to download the file to the desktop
seems like a misplaced feature since that it available in other places in the
UI. Suggest to just create a link.

Version-Release number of selected component (if applicable):

1.0.3-5

Additional Info:

This feature really rocks and I've missed it since Galeon or something. I
discovered the feature (and this bug) while casually seeing if Firefox had
gotten this feature since it was inevitable to show up :-)

Comment 1 Jeremy Katz 2005-05-24 20:42:59 UTC
Although this feature is nice and could work better, I have a hard time seeing
this being a blocker for FC4

Comment 2 Matthias Clasen 2006-02-16 06:47:11 UTC
Hmm, I still get the ask cursor, but no dialog upon drop with firefox 1.5.
Is this bug obsolete, David ?

Comment 3 David Zeuthen 2006-02-16 16:29:39 UTC
Well, parts of it is obsolete since things got fixed or something. I'm also
puzzled by the fact that I got a "ask cursor" but I kinda like just giving me a
link instead of asking me questions.

Comment 4 Matthias Clasen 2006-07-28 03:12:43 UTC
Currently dragging to the desktop does not work at all. 
Alex says there may be a fix in cvs nautilus, need to check that.

Comment 5 Matthias Clasen 2006-07-28 04:54:08 UTC
*** Bug 200398 has been marked as a duplicate of this bug. ***

Comment 6 Matthias Clasen 2006-08-04 20:43:07 UTC
Still happens with nautilus-2.15.90

Comment 7 Matthias Clasen 2006-08-05 17:37:04 UTC
Upstream bug has a Manny patch.

Comment 8 Alexander Larsson 2006-08-11 13:41:41 UTC
It still shows an ask cursor but then it just links, but the "it broke
completely"  part is fixed.

Comment 9 Matěj Cepl 2007-12-20 16:47:11 UTC
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays


Note You need to log in before you can comment on or make changes to this bug.