Bug 1576023 - vim-enhanced will not upgrade
Summary: vim-enhanced will not upgrade
Keywords:
Status: CLOSED DUPLICATE of bug 1575354
Alias: None
Product: Fedora
Classification: Fedora
Component: vim
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-08 15:02 UTC by bodhi.zazen
Modified: 2018-05-09 02:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 02:43:33 UTC
Type: Bug


Attachments (Terms of Use)

Description bodhi.zazen 2018-05-08 15:02:12 UTC
Description of problem: vim-enhanced will not upgrade


Version-Release number of selected component (if applicable):

vim-enhanced-2:8.0.1788-1.fc28.x86_64

How reproducible: Always on upgrade


Steps to Reproduce:

1. run sudo dnf upgrade



Actual results:

sudo dnf upgrade
Last metadata expiration check: 0:08:12 ago on Mon 07 May 2018 03:57:33 AM AKDT.
Dependencies resolved.

 Problem 1: cannot install the best update candidate for package vim-enhanced-2:8.0.1704-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
 Problem 2: problem with installed package vim-enhanced-2:8.0.1704-1.fc28.x86_64
  - package vim-enhanced-2:8.0.1704-1.fc28.x86_64 requires vim-common = 2:8.0.1704-1.fc28, but none of the providers can be installed
  - cannot install both vim-common-2:8.0.1788-1.fc28.x86_64 and vim-common-2:8.0.1704-1.fc28.x86_64
  - cannot install both vim-common-2:8.0.1704-1.fc28.x86_64 and vim-common-2:8.0.1788-1.fc28.x86_64
  - cannot install the best update candidate for package vim-common-2:8.0.1704-1.fc28.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.26.2) needed by vim-enhanced-2:8.0.1788-1.fc28.x86_64
=======================================================================================================
 Package                  Arch               Version                         Repository           Size
=======================================================================================================
Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 vim-common               x86_64             2:8.0.1788-1.fc28               updates             6.4 M
Skipping packages with broken dependencies:
 vim-enhanced             x86_64             2:8.0.1788-1.fc28               updates             1.3 M

Transaction Summary
=======================================================================================================
Skip  2 Packages

Nothing to do.
Complete!


Expected results: vim-enhanced should update


Additional info:

Comment 1 andrey i. mavlyanov 2018-05-08 15:21:48 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1575354

Comment 2 Alick Zhao 2018-05-09 02:43:33 UTC

*** This bug has been marked as a duplicate of bug 1575354 ***


Note You need to log in before you can comment on or make changes to this bug.