Bug 1576025 - Backport commit 3be6063729017060fbca41970fa1ab7768be37e4
Summary: Backport commit 3be6063729017060fbca41970fa1ab7768be37e4
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dbus
Version: 7.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: David King
QA Contact: Desktop QE
URL:
Whiteboard:
: 1576026 (view as bug list)
Depends On:
Blocks: 1576026
TreeView+ depends on / blocked
 
Reported: 2018-05-08 15:08 UTC by Renaud Métrich
Modified: 2019-08-19 12:26 UTC (History)
4 users (show)

Fixed In Version: dbus-1.8.6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1576026 (view as bug list)
Environment:
Last Closed: 2019-08-19 12:26:34 UTC
Target Upstream Version:


Attachments (Terms of Use)
dist-git patch, which builds fine locally (5.18 KB, patch)
2018-10-26 09:24 UTC, David King
no flags Details | Diff

Description Renaud Métrich 2018-05-08 15:08:14 UTC
Description of problem:

Please backport commit 3be6063729017060fbca41970fa1ab7768be37e4 to RHEL7.3 EUS's dbus.
This commit fixes a critical bug where all processes on the system can be inadvertently killed in case dbus-launch starts but session doesn't initialize well.

The fix is straightforward and present no risk

Version-Release number of selected component (if applicable):

dbus-1.6.12-17

How reproducible:

Don't know, but happens sometimes.

Comment 3 David King 2018-10-26 09:24:49 UTC
Created attachment 1497668 [details]
dist-git patch, which builds fine locally

Comment 4 Tomas Pelka 2019-01-31 14:53:55 UTC
*** Bug 1576026 has been marked as a duplicate of this bug. ***

Comment 5 David King 2019-08-19 12:26:34 UTC
This is fixed in dbus-1.8.6, which is already included in recent versions of RHEL 7.


Note You need to log in before you can comment on or make changes to this bug.