Bug 1576068 - [RFE] Need user friendly virt-who message when it is unable to connect to the satellite server
Summary: [RFE] Need user friendly virt-who message when it is unable to connect to the...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virt-who
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: William Poteat
QA Contact: Eko
URL:
Whiteboard:
: 1576069 1715147 (view as bug list)
Depends On:
Blocks: 1715147
TreeView+ depends on / blocked
 
Reported: 2018-05-08 17:23 UTC by Anitha Udgiri
Modified: 2020-06-14 19:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1715147 (view as bug list)
Environment:
Last Closed: 2020-06-14 19:06:12 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Anitha Udgiri 2018-05-08 17:23:58 UTC
Description of problem:

Customer sees the following error messages when trying to debug another issue.

May  7 09:52:24 evevh023 /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:37 evevh023 /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:37 evevh023 /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:38 evevh023 /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:39 evevh023 python: detected unhandled Python exception in '/usr/bin/virt-who'
May  7 09:52:39 evevh023 virt-who: Traceback (most recent call last):
May  7 09:52:39 evevh023 virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4645, in _dispatchDomainEventCallbacks
May  7 09:52:39 evevh023 virt-who: cb(self, virDomain(self, _obj=dom), event, detail, opaque)
May  7 09:52:39 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 221, in _callback
May  7 09:52:39 evevh023 virt-who: report = self._get_report()
May  7 09:52:39 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 229, in _get_report
May  7 09:52:39 evevh023 virt-who: return DomainListReport(self.config, self._listDomains(), self._remote_host_id())
May  7 09:52:39 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 274, in _listDomains
May  7 09:52:39 evevh023 virt-who: raise VirtError(str(e))
May  7 09:52:39 evevh023 virt-who: virtwho.virt.virt.VirtError: Domain not found: no domain with matching uuid '506ef4a7-b9db-4853-9344-a313b12e04b0' (evevs003)
May  7 09:52:39 evevh023 /usr/bin/virt-who: [ERROR] @virt.py:389 - Thread 'env/cmdline' fails with exception:#012libvirtError: invalid connection pointer in virConnectIsAlive
May  7 09:52:39 evevh023 /usr/bin/virt-who: [INFO] @virt.py:888 - Report for config "env/cmdline" gathered, placing in datastore
May  7 09:52:39 evevh023 /usr/bin/virt-who: [INFO] @virt.py:408 - Waiting 3600 seconds before performing action again 'env/cmdline'
May  7 09:52:55 evevh023 virt-who: Traceback (most recent call last):
May  7 09:52:55 evevh023 virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4645, in _dispatchDomainEventCallbacks
May  7 09:52:55 evevh023 virt-who: cb(self, virDomain(self, _obj=dom), event, detail, opaque)
May  7 09:52:55 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 221, in _callback
May  7 09:52:55 evevh023 virt-who: report = self._get_report()
May  7 09:52:55 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 229, in _get_report
May  7 09:52:55 evevh023 virt-who: return DomainListReport(self.config, self._listDomains(), self._remote_host_id())
May  7 09:52:55 evevh023 virt-who: File "/usr/lib/python2.7/site-packages/virtwho/virt/libvirtd/libvirtd.py", line 273, in _listDomains
May  7 09:52:55 evevh023 virt-who: self.virt.close()
May  7 09:52:55 evevh023 virt-who: File "/usr/lib64/python2.7/site-packages/libvirt.py", line 3523, in close
May  7 09:52:55 evevh023 virt-who: if ret == -1: raise libvirtError ('virConnectClose() failed', conn=self)
May  7 09:52:55 evevh023 virt-who: libvirt.libvirtError: invalid connection pointer in virConnectClose

They think these are caused by out Satellite Downtime (since they are doing a backup of Satellite before upgrades).

Expected behaviour:
- Do not flood the messages with these cryptic error reports
- Just print "Could not connect to Satellite server A.domain.com "


They are not entirely sure if this cause by the satellite being down or anything else.

The RFE here is for RedHat to provide a user friendly error message when the satellite is down so that these messages can be easily distinguished without needing to log a support call.

Comment 3 William Poteat 2019-05-28 15:12:16 UTC
*** Bug 1576069 has been marked as a duplicate of this bug. ***

Comment 4 William Poteat 2019-06-03 19:46:42 UTC
I need the version of virt-who.
Is what is the configuration of this setup?

Comment 5 William Poteat 2019-06-03 19:52:11 UTC
I need the version of virt-who.
Is what is the configuration of this setup?

Comment 6 William Poteat 2019-06-24 14:34:30 UTC
*** Bug 1715147 has been marked as a duplicate of this bug. ***

Comment 7 Anitha Udgiri 2019-06-25 21:11:50 UTC
(In reply to William Poteat from comment #4)
> I need the version of virt-who.
> Is what is the configuration of this setup?

virt-who-0.17-11.el7_3 as per the package manifest for RHV 4.1

Comment 8 William Poteat 2019-10-22 12:21:49 UTC
Will evaluate with current releases

Comment 9 Rich Jerrido 2020-06-05 08:31:49 UTC
Thank you for your interest. We have evaluated this request, and
while we recognize that it is a valid request, we do not expect this to be
implemented in the product in the foreseeable future. This is due to other
priorities for the product, and not a reflection on the request itself. We are
therefore closing this out as WONTFIX. If you have any concerns about this,
please do not reopen. Instead, feel free to contact Red Hat Technical Support.
Thank you.


Note You need to log in before you can comment on or make changes to this bug.