Bug 1576240 - Systemd fails to mount cgroups (devices, memory, ...) on F28 without systemd dracut module
Summary: Systemd fails to mount cgroups (devices, memory, ...) on F28 without systemd ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 06:43 UTC by lapseofreason0
Modified: 2018-05-13 20:01 UTC (History)
6 users (show)

Fixed In Version: systemd-238-8.git0e0aa59.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-13 20:01:12 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/systemd systemd issues 7901 0 None None None 2018-05-09 06:43:51 UTC

Description lapseofreason0 2018-05-09 06:43:52 UTC
Description of problem:

Systemd fails to mount most cgroups (/sys/fs/cgroup/devices, /sys/fs/cgroup/memory, ...) after upgrade from F27 to F28. This seems to be the case only when the systemd dracut module is not present, which happens for example if the crypt-gpg dracut module is used.

Most likely this is caused by the following bug:
https://github.com/systemd/systemd/issues/7901

Should be fixed by:
https://github.com/systemd/systemd/pull/8595


Version-Release number of selected component (if applicable):

systemd-238-7.fc28.1


How reproducible:
Always


Steps to Reproduce:
1. Create a file /etc/dracut.conf.d/10-no-systemd.conf with the content 'omit_dracutmodules+=" systemd "'.
2. Rebuild initramfs with dracut -f.
3. Reboot and check /proc/mounts.


Actual results:

# cat /proc/mounts | grep cgroup
tmpfs /sys/fs/cgroup tmpfs ro,seclabel,nosuid,nodev,noexec,mode=755 0 0
cgroup2 /sys/fs/cgroup/unified cgroup2 rw,seclabel,nosuid,nodev,noexec,relatime,nsdelegate 0 0
cgroup /sys/fs/cgroup/systemd cgroup rw,seclabel,nosuid,nodev,noexec,relatime,xattr,name=systemd 0 0


Expected results:

Cgroups for devices, memory, etc. should be present in /sys/fs/cgroup/devices, /sys/fs/cgroup/memory, etc.


Additional info:

This bug prevents docker from working. The bug is not present in F27.
Could be related to https://bugzilla.redhat.com/show_bug.cgi?id=1574649.

Comment 1 Zbigniew Jędrzejewski-Szmek 2018-05-09 08:39:52 UTC
Yeah, looks we need to apply that patch.

Comment 2 lapseofreason0 2018-05-09 12:17:17 UTC
Great, thanks for the quick response.

I'd be happy to test if you can provide a patched build.

Comment 3 Zbigniew Jędrzejewski-Szmek 2018-05-11 11:24:46 UTC
Please test the update.

Comment 4 Fedora Update System 2018-05-11 11:24:49 UTC
systemd-238-8.git0e0aa59.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-f455e48805

Comment 5 Fedora Update System 2018-05-11 18:52:19 UTC
systemd-238-8.git0e0aa59.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-f455e48805

Comment 6 lapseofreason0 2018-05-12 07:18:31 UTC
Works like a charm, thanks!

Comment 7 Fedora Update System 2018-05-13 20:01:12 UTC
systemd-238-8.git0e0aa59.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.