Bug 1576304 - [abrt] docker-compose: _cmp(): version.py:337:_cmp:TypeError: '<' not supported between instances of 'str' and 'int'
Summary: [abrt] docker-compose: _cmp(): version.py:337:_cmp:TypeError: '<' not support...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: docker-compose
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Hampton
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8ea4a8c7317772bda6a4f3d6598...
: 1626512 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:05 UTC by František Zatloukal
Modified: 2018-09-07 14:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 08:08:36 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.72 KB, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: cgroup (365 bytes, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: cpuinfo (1.46 KB, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: environ (6.36 KB, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: mountinfo (4.40 KB, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: namespaces (129 bytes, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
File: open_fds (246 bytes, text/plain)
2018-05-09 08:05 UTC, František Zatloukal
no flags Details
compose.yml (449 bytes, text/plain)
2018-05-09 08:06 UTC, František Zatloukal
no flags Details

Description František Zatloukal 2018-05-09 08:05:18 UTC
Description of problem:
Crashed after running "docker-compose up -d"

Version-Release number of selected component:
docker-compose-1.20.1-1.fc28

Additional info:
reporter:       libreport-2.9.5
cmdline:        /usr/bin/python3 /usr/bin/docker-compose up -d
crash_function: _cmp
exception_type: TypeError
executable:     /usr/bin/docker-compose
interpreter:    python3-3.6.5-1.fc28.x86_64
kernel:         4.16.6-302.fc28.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
version.py:337:_cmp:TypeError: '<' not supported between instances of 'str' and 'int'

Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 11, in <module>
    load_entry_point('docker-compose==1.20.1', 'console_scripts', 'docker-compose')()
  File "/usr/lib/python3.6/site-packages/compose/cli/main.py", line 71, in main
    command()
  File "/usr/lib/python3.6/site-packages/compose/cli/main.py", line 124, in perform_command
    project = project_from_options('.', options)
  File "/usr/lib/python3.6/site-packages/compose/cli/command.py", line 41, in project_from_options
    compatibility=options.get('--compatibility'),
  File "/usr/lib/python3.6/site-packages/compose/cli/command.py", line 113, in get_project
    config_data = config.load(config_details, compatibility)
  File "/usr/lib/python3.6/site-packages/compose/config/config.py", line 380, in load
    for config_file in config_details.config_files
  File "/usr/lib/python3.6/site-packages/compose/config/config.py", line 380, in <listcomp>
    for config_file in config_details.config_files
  File "/usr/lib/python3.6/site-packages/compose/config/config.py", line 513, in process_config_file
    config_file.get_service_dicts(),
  File "/usr/lib/python3.6/site-packages/compose/config/config.py", line 221, in get_service_dicts
    return self.config if self.version == V1 else self.config.get('services', {})
  File "/usr/lib64/python3.6/distutils/version.py", line 46, in __eq__
    c = self._cmp(other)
  File "/usr/lib64/python3.6/distutils/version.py", line 337, in _cmp
    if self.version < other.version:
TypeError: '<' not supported between instances of 'str' and 'int'

Local variables in innermost frame:
other: LooseVersion ('1')
self: LooseVersion ('‘2’')

Comment 1 František Zatloukal 2018-05-09 08:05:25 UTC
Created attachment 1433599 [details]
File: backtrace

Comment 2 František Zatloukal 2018-05-09 08:05:27 UTC
Created attachment 1433600 [details]
File: cgroup

Comment 3 František Zatloukal 2018-05-09 08:05:29 UTC
Created attachment 1433601 [details]
File: cpuinfo

Comment 4 František Zatloukal 2018-05-09 08:05:30 UTC
Created attachment 1433602 [details]
File: environ

Comment 5 František Zatloukal 2018-05-09 08:05:32 UTC
Created attachment 1433603 [details]
File: mountinfo

Comment 6 František Zatloukal 2018-05-09 08:05:34 UTC
Created attachment 1433604 [details]
File: namespaces

Comment 7 František Zatloukal 2018-05-09 08:05:37 UTC
Created attachment 1433605 [details]
File: open_fds

Comment 8 František Zatloukal 2018-05-09 08:06:37 UTC
Created attachment 1433606 [details]
compose.yml

Comment 9 Lucas 2018-09-07 14:08:28 UTC
*** Bug 1626512 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.