Bug 1576307 - Default Repository download policy is being ignored when synchronising repos
Summary: Default Repository download policy is being ignored when synchronising repos
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Repositories
Version: 6.3.1
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: vijsingh
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:14 UTC by May
Modified: 2019-07-02 17:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-02 17:53:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description May 2018-05-09 08:14:54 UTC
Description of problem:
Before enabling repos we set the default repo download policy to immediate.
Then we enabled the repos but they are still downloading in an 'on demand' state.

Version-Release number of selected component (if applicable):
6.3.1

How reproducible:


Steps to Reproduce:
1. Set Default Repository download policy to immediate:
Administer > settings > content > Default Repository download policy -immediate.
2. Enable repos to sync
3. Sync repos

Actual results:
Repos download still uses 'on demand' state.


Expected results:
Repos download should use 'immediate' state


Additional info:
Bypassed by setting the repos to 'immediate' individually:
Content > products > click on repo > set download policy to 'immediate' for each repository.

Comment 1 Tanya Tereshchenko 2018-05-09 17:47:59 UTC
Hi Brad,
I would guess it's somewhere on the Katello side. Maybe the cause is the same as in BZ#1573590.
It's worth checking that the download policy on the importer is changed or there are no Pulp errors in the logs. If it turns out to be a Pulp issue, please provide API calls with params for the suspicious Pulp behaviour.

I'm changing the component to start investigation on your side.

Comment 3 Bryan Kearney 2019-07-02 17:53:28 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.