Bug 1576322 - Storage class drop-down item with type could just take one line height
Summary: Storage class drop-down item with type could just take one line height
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 08:37 UTC by Xingxing Xia
Modified: 2018-05-09 12:42 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 12:42:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
Type takes one line in 3.10 (27.05 KB, image/png)
2018-05-09 08:37 UTC, Xingxing Xia
no flags Details
Type takes no other line in ded int aws 3.7 (49.72 KB, image/png)
2018-05-09 08:38 UTC, Xingxing Xia
no flags Details
In case of long extra paramateres lines are not breaking (100.50 KB, image/png)
2018-05-09 11:45 UTC, Jakub Hadvig
no flags Details
Breaking lines in case of long extra parameters (111.41 KB, image/png)
2018-05-09 11:46 UTC, Jakub Hadvig
no flags Details

Description Xingxing Xia 2018-05-09 08:37:18 UTC
Created attachment 1433617 [details]
Type takes one line in 3.10

Description of problem:
Storage class drop-down item with type could just take one line height

Version-Release number of selected component (if applicable):
v3.10.0-0.37.0

How reproducible:
Always

Steps to Reproduce:
1. In env with storage class that has a type, go to storage page to create storage
2. Check the storage class drop-down list

Actual results:
2. The item with type takes 2 lines height: name one line and type the other (see attachment)

Expected results:
2. The item with type could just take one line for consistent height display, like 3.7 ded-int-aws (see attachment)

Additional info:
3.9 free-stg reproduces too.

Comment 1 Xingxing Xia 2018-05-09 08:38:03 UTC
Created attachment 1433618 [details]
Type takes no other line in ded int aws 3.7

Comment 2 Jakub Hadvig 2018-05-09 11:43:27 UTC
Dont think this is a bug.Type/Zone/Access/description params have visibly different size and are muted, which tells user that they are extra.
If anything I've noticed during testing that extra params are not breaking in case they are too long. 
Attaching screenshots

Comment 3 Jakub Hadvig 2018-05-09 11:45:03 UTC
Created attachment 1433763 [details]
In case of long extra paramateres lines are not breaking

Comment 4 Jakub Hadvig 2018-05-09 11:46:17 UTC
Created attachment 1433764 [details]
Breaking lines in case of long extra parameters

Comment 5 Samuel Padgett 2018-05-09 12:42:35 UTC
> The item with type takes 2 lines height: name one line and type the other (see attachment)

This is working as intended. For consistency, we show the storage class metadata always on the second line since it often has a description which takes some space. It would be odd for some metadata to appear on the same line and others on the second line, not to mention that the dropdown items would be different heights. It's better to always be able to look at the same place for the information.

Similarly we do not wrap text since it would cause layout problems if the description were very long.


Note You need to log in before you can comment on or make changes to this bug.