Bug 1576358 - java.util.zip.ZipException: invalid entry compressed size during Eclipse build using xmvn
Summary: java.util.zip.ZipException: invalid entry compressed size during Eclipse buil...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xmvn
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mikolaj Izdebski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-09 09:27 UTC by Mat Booth
Modified: 2019-04-09 18:44 UTC (History)
4 users (show)

Fixed In Version: xmvn-3.0.0-17.fc28 xmvn-3.0.0-18.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-09 18:44:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Mat Booth 2018-05-09 09:27:25 UTC
I've suddenly started experiencing this error in F28 koschie builds for aarch64:

https://apps.fedoraproject.org/koschei/package/eclipse?collection=f28

Here is sample log file output from https://kojipkgs.fedoraproject.org//work/tasks/3719/26813719/build.log

+ xmvn-install -R .xmvn-reactor -n eclipse -d /builddir/build/BUILDROOT/eclipse-4.7.3a-4.fc28.aarch64
Unhandled exception
java.lang.RuntimeException: java.util.zip.ZipException: invalid entry compressed size (expected 16792 but got 16793 bytes)
	at org.fedoraproject.xmvn.tools.install.JarUtils.injectManifest(JarUtils.java:271)
	at org.fedoraproject.xmvn.tools.install.impl.DefaultArtifactInstaller.install(DefaultArtifactInstaller.java:85)
	at org.fedoraproject.xmvn.tools.install.impl.DefaultInstaller.installArtifact(DefaultInstaller.java:223)
	at org.fedoraproject.xmvn.tools.install.impl.DefaultInstaller.install(DefaultInstaller.java:335)
	at org.fedoraproject.xmvn.tools.install.cli.InstallerCli.run(InstallerCli.java:57)
	at org.fedoraproject.xmvn.tools.install.cli.InstallerCli.main(InstallerCli.java:82)
Caused by: java.util.zip.ZipException: invalid entry compressed size (expected 16792 but got 16793 bytes)
	at java.util.zip.ZipOutputStream.closeEntry(ZipOutputStream.java:267)
	at java.util.zip.ZipOutputStream.putNextEntry(ZipOutputStream.java:192)
	at java.util.jar.JarOutputStream.putNextEntry(JarOutputStream.java:109)
	at org.fedoraproject.xmvn.tools.install.JarUtils.injectManifest(JarUtils.java:261)
	... 5 more
	Suppressed: java.util.zip.ZipException: invalid entry compressed size (expected 16792 but got 16793 bytes)
		at java.util.zip.ZipOutputStream.closeEntry(ZipOutputStream.java:267)
		at java.util.zip.ZipOutputStream.finish(ZipOutputStream.java:360)
		at java.util.zip.DeflaterOutputStream.close(DeflaterOutputStream.java:238)
		at java.util.zip.ZipOutputStream.close(ZipOutputStream.java:377)
		at org.fedoraproject.xmvn.tools.install.JarUtils.injectManifest(JarUtils.java:267)
		... 5 more


This looks exactly like bug 1566614 I reported earlier against the rh-maven35 collection.

Comment 1 Mikolaj Izdebski 2018-05-09 09:31:12 UTC
I'll apply upstream patch from https://github.com/fedora-java/xmvn/pull/27

Comment 2 Mikolaj Izdebski 2018-05-09 10:04:46 UTC
Fixed in xmvn-3.0.0-16

Comment 3 Fedora Update System 2018-05-09 10:40:12 UTC
xmvn-3.0.0-16.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-00031e9c1c

Comment 4 Mikolaj Izdebski 2018-05-09 10:41:47 UTC
I've added buildroot override for Fedora 28, https://bodhi.fedoraproject.org/overrides/xmvn-3.0.0-16.fc28
Lets see if it fixes package statuses in Koschei.

Comment 5 Mat Booth 2018-05-09 11:04:12 UTC
Thanks Mikolaj

Comment 6 Fedora Update System 2018-05-10 01:30:47 UTC
xmvn-3.0.0-16.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-00031e9c1c

Comment 7 Fedora Update System 2018-05-18 09:54:38 UTC
xmvn-3.0.0-17.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-00031e9c1c

Comment 8 Fedora Update System 2018-05-19 04:19:40 UTC
xmvn-3.0.0-17.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-00031e9c1c

Comment 9 Fedora Update System 2018-05-28 15:23:58 UTC
xmvn-3.0.0-17.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.