Bug 157640 - Kickstart FTP Install Fails to Bring up Network Interface with Static IP
Kickstart FTP Install Fails to Bring up Network Interface with Static IP
Status: CLOSED DUPLICATE of bug 149871
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: pump (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2005-05-13 08:31 EDT by Rafiq Maniar
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-05-16 16:16:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Rafiq Maniar 2005-05-13 08:31:28 EDT
Description of problem:

Note: The problem is more to do with kickstart than pump, but there was no 
kickstart entry in 'component'.

When doing an FTP install via a kickstart file, the installation prompts for an 
IP address, netmask, etc when no DHCP server is found, but does not bring up 
the network interface. With a DHCP server on the network, the interface is 
brought up and the same kickstart file installs the system fine.

Martin Poole @ Redhat has been involved in troubleshooting this problem. We 
have a workaround but the root cause needs to be analysed and resolved. Tested 
on RHEL4, RHEL3U3, RHEL3U4 with the same behaviour.

The workaround is to specify "ip=::::::" on the boot line in addition to 
the "ks=" parameter. The user will still be prompted for IP address information 
during the installation but it will actually bring up the network interface 
with this line. Properly specifying the IP information on the command line 
(eg. "ip=") does NOT bring up the network 
interface by itself and STILL prompts for all the IP address information during 

Systems: Dell PowerEdge 1855 (two NICs) + PowerEdge 700 (one NIC).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Setup ks.cfg and an installation tree on an FTP server
2. Ensure no DHCP server on the network.
3. Boot with "ks=ftp://<ip>/<path>" (eg 
4. Enter the IP address information when prompted and select OK
Actual results:
The network interface is NOT brought up and installation defaults back to CD 
after being unable to receive the ks.cfg.

Expected results:
The network interface should be brought up, and the ks.cfg should be 
transferred from the FTP server and used to install the machine.

Additional info:

Virtual Console 3
* running dhcp for eth0
* pump told us: No DHCP reply received
* isn't a wireless adaptor
<VC1 prompt for IP address, enter and select ok>
* result of pumpSetupInterface is SIOCSIFADDR: No such device
* waiting for link...
* 0 seconds
* reverse name lookup failed
* ks location:
* transferring ftp://10.2.31//./as4.0/ks.cfg to a fd
* failed to retrieve
<mounts the CD and does a cd installation>
Comment 1 Jeremy Katz 2005-05-16 16:16:54 EDT
Will be fixed in U1.

*** This bug has been marked as a duplicate of 149871 ***

Note You need to log in before you can comment on or make changes to this bug.