Bug 157653 - Cannot invoke CVS repository perspective
Cannot invoke CVS repository perspective
Status: CLOSED CURRENTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: Platform (Show other bugs)
2.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-13 10:19 EDT by Rick Moseley
Modified: 2007-04-18 13:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.0.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-25 08:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.log from .metadata after trying to open a cvs repositiory perspective (43.51 KB, text/plain)
2005-05-13 11:36 EDT, Rick Moseley
no flags Details

  None (edit)
Description Rick Moseley 2005-05-13 10:19:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Firefox/1.0.2 Red Hat/1.0.2-1.4.1

Description of problem:
When trying to bring up the CVS repository an error windw appears with the following message:
  Problems opening perspective org.eclipse.team.cvs.ui.cvsPerspective

This all occurred after "rm -rf .eclipse" and starting in a brand new workspace.

Here is the result of a "rpm -qa | grep eclipse | sort"

eclipse-cdt-2.1.1-3
eclipse-cdt-debuginfo-2.1.1-3
eclipse-changelog-2.0.1-5
eclipse-changelog-debuginfo-2.0.1-5
eclipse-debuginfo-3.0.2-1
eclipse-emf-2.0.1-6
eclipse-emf-debuginfo-2.0.1-6
eclipse-gef-3.0.1-7
eclipse-gef-debuginfo-3.0.1-7
eclipse-gtk2-3.0.2-1
eclipse-jdt-3.0.2-1
eclipse-lomboz-3.0.1-9
eclipse-lomboz-debuginfo-3.0.1-9
eclipse-oprofile-1.2.0-2
eclipse-oprofile-debuginfo-1.2.0-2
eclipse-pde-3.0.2-1
eclipse-platform-3.0.2-1
eclipse-rpm-1.2.0-4
eclipse-rpm-debuginfo-1.2.0-4
eclipse-scripts-3.0.2-1
eclipse-source-3.0.2-1
eclipse-ve-3.0.1-4
eclipse-ve-debuginfo-3.0.1-4

rpm -qa | grep java

java-1.4.2-gcj-compat-1.4.2.0-26jpp
java-1.4.2-gcj-compat-devel-1.4.2.0-26jpp
gcc-java-3.4.3-9.EL4
java-1.4.2-ibm-1.4.2.1-1jpp_2rh


Version-Release number of selected component (if applicable):
eclipse-platform-3.0.2-1

How reproducible:
Always

Steps to Reproduce:
1. start up eclipse
2. try to open the CVS repository perspective
3.
  

Actual Results:  error message described above occurs

Expected Results:  CVS repository perspective opens

Additional info:
Comment 1 Andrew Overholt 2005-05-13 10:37:45 EDT
What are your java and javac alternatives set to, Rick?  The output of rpm -qa |
grep java isn't as interesting as the output of, say:

which java
java -version
which javac
javac -version

So what JVM are you running this with?
Comment 2 Rick Moseley 2005-05-13 10:55:08 EDT
which java
/usr/bin/java

ls -la /usr/bin/java
/usr/bin/java -> /etc/alternatives/java


ls -la /etc/alternatives/java
/etc/alternatives/java -> /usr/lib/jvm/java-1.4.2-ibm-1.4.2.1/jre/bin/java

java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
Classic VM (build 1.4.2, J2RE 1.4.2 IBM build cxia32142-20041210 (JIT enabled:
jitc))

 which javac
/usr/bin/javac

ls -la /usr/bin/javac
/usr/bin/javac -> /etc/alternatives/javac

ls -la /etc/alternatives/javac
/etc/alternatives/javac -> /usr/lib/jvm/java-1.4.2-gcj/bin/javac

javac -version
Eclipse Java Compiler 0.319_R21x, Copyright IBM Corp 2000-2003. All rights reserved.



Comment 3 Ben Konrath 2005-05-13 11:16:17 EDT
Is this happening on RHEL-4? Can you attach the workspace/.metadata/.log file?
Thanks.
Comment 4 Rick Moseley 2005-05-13 11:36:22 EDT
Created attachment 114339 [details]
.log from .metadata after trying to open a cvs repositiory perspective

This log was generated fom a clean workspace and the only thing done was to try
to activate a CVS Repository Browsing perspective.
Comment 5 Rick Moseley 2005-05-13 11:38:39 EDT
Yes this is from a RHEL 4 machine.

cat /etc/redhat-release
Red Hat Enterprise Linux AS release 4 (Nahant)

uname -a
Linux dhcp-232.hsv.redhat.com 2.6.9-5.0.3.EL #1 Mon Feb 14 09:52:18 EST 2005
i686 i686 i386 GNU/Linux


Comment 6 Rick Moseley 2005-05-13 14:11:16 EDT
Wow, I cannot get eclipse to come up with the Sun JVM.

java -version
java version "1.4.2_08"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_08-b03)
Java HotSpot(TM) Client VM (build 1.4.2_08-b03, mixed mode)


I get the following error log in ~/.eclipse/org.eclipse.platform_3.0.2/configuration

!SESSION May 13, 2005 13:05:32.133 ---------------------------------------------
eclipse.buildId=200503110845
java.version=1.4.2_08
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US

!ENTRY org.eclipse.osgi May 13, 2005 13:05:32.134
!MESSAGE Application error
!STACK 1
java.lang.UnsatisfiedLinkError: /usr/lib/eclipse/libswt-pi-gtk-3064.so:
/usr/lib/eclipse/libswt-pi-gtk-3064.so: undefined symbol: XTestFakeButtonEvent
Comment 7 Rick Moseley 2005-05-13 15:21:42 EDT
The Blackdown JVM yeilds the same problem as the IBM one.

java -version
java version "1.4.2-01"
Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.4.2-01)
Java HotSpot(TM) Client VM (build Blackdown-1.4.2-01, mixed mode)
Comment 8 Matt Wringe 2005-05-19 10:59:23 EDT
I am using RHEL4 and I am also coming across similar errors. I get similar
errors to the one posted below when I try and do anything with cvs:
"Plug-in org.eclipse.team.cvs.ui was unable to load class
org.eclipse.team.internal.ccvs.ui.CVSPropetiesPage."

Info:
-eclipse-plateform-3.0.2-1
-java-1.4.2-ibm-1.4.2.0-1jpp_8rh
Comment 9 Phil Muldoon 2005-05-24 17:16:19 EDT
Setting LD_LIBRARY_PATH=/usr/lib/eclipse and the CVS perspective sill work
(basically eclipse complains it cannot find libcvs.so)

Not sure why this is the case in 3.0.2. Investigating.
Comment 10 Ben Konrath 2005-05-24 22:11:17 EDT
The problem was that %{eclipse_majmin}.%{eclipse_micro} (3.0.2) was being used
to install the .sos and Eclipse only changes plugin versions if code in the
plugin has changed during that release cycle. The cvs plugin is at 3.0.1 in
Eclipse 3.0.2  so libcvs.so was installed in the wrong place. I fixed this and a
similar problem with the core.resources plugin.
Comment 11 Rick Moseley 2005-05-25 08:39:38 EDT
Works with 3.0.2-2 packages.  Good work Ben!

Note You need to log in before you can comment on or make changes to this bug.