Bug 157684 - ldap searches hang at ldap_int_select
ldap searches hang at ldap_int_select
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openldap (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Jay Turner
http://www.openldap.org/its/index.cgi...
:
Depends On:
Blocks: 159436 176344
  Show dependency treegraph
 
Reported: 2005-05-13 14:43 EDT by Brian Nelson
Modified: 2015-01-07 19:09 EST (History)
5 users (show)

See Also:
Fixed In Version: openldap-2.2.13-5.4E
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-31 15:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch against openldap 2.2.16 that fixes the problem. (1.11 KB, patch)
2005-05-13 14:43 EDT, Brian Nelson
no flags Details | Diff
`ldapsearch' output up to a hang (24.81 KB, application/octet-stream)
2006-07-09 21:49 EDT, Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
no flags Details

  None (edit)
Description Brian Nelson 2005-05-13 14:43:14 EDT
+++ This bug was initially created as a clone of Bug #135188 +++

Description of problem:

When using openldap tools on RHEL4, lookups hang at ldap_int_select.
This was reported against Active Directory, but it also happens against
Novell eDirectory (in my case) and possibly others.

The issue has been described, addressed and fixed in OpenLDAP 2.2.16:

http://www.openldap.org/its/index.cgi/Software%20Bugs?id=3250


Version-Release number of selected component (if applicable):

openldap-2.2.13-2

How reproducible:

Every time.

Steps to Reproduce:

Run an ldapsearch against an LDAP database 
  
Actual results:
Hangs after displaying results, before displaying summary.

Expected results:
No hang.

Additional info:

Patch against openldap 2.2.15 -> 2.2.16 attached.
Comment 1 Brian Nelson 2005-05-13 14:43:15 EDT
Created attachment 114349 [details]
Patch against openldap 2.2.16 that fixes the problem.
Comment 2 Brian Nelson 2005-10-31 17:00:19 EST
This has been 'NEW' for almost six months. Can it please be addressed?

I have checked that this problem still has not been corrected in the newest
openldap packages (2.2.13-4).
Comment 3 Brian Nelson 2006-02-02 16:28:10 EST
Over eight months old now. Can someone please address this?? I don't think I
could have made it any easier.
Comment 4 Jay Fenlason 2006-05-01 16:44:45 EDT
The patch for this bug will be included in the upcoming RHEL-4U4 release, 
barring suprises during QA. 
Comment 5 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-07-09 21:43:08 EDT
I've experienced a similar problem.

Mine exhibits against Novell eDirectory/LDAP server but only when secured
connection is used. Non-encrypted connections don't have this problem. Secured
connections fail both via SSL (`ldaps://...' URL) as well as when using STARTTLS
(`-Z' or `-ZZ' options). I have no such problem when connecting against
OpenLDAP's slapd (though it's a version different from that of client and runs
on a different machine).

To prevent any potential confusion: The failure strikes at a moment, when almost
all the output of `ldapsearch' has been printed. The only part which doesn't get
through is:

   # search result
   search: 2
   result: 0 Success

   # numResponses: 2
   # numEntries: 1

Using a newer version has fixed the problem as expected. I tested this sometimes
in 1Q/2006 or by the beginning of 2Q/2006 with a rebuilt SRPM from Fedora Core
(don't remember which one -- whether 4, 5 or devel). Surely the version number
was newer than that of  available package.

Do you think I might be experiencing the same bug? If this is not the case, I'd
better file a barnd new bug then...

Well, I started to doubt about the answer to my question. However running the
beast (with debug on: `-d 99' -- don't know what range `-d' really accepts)
again, it seems to have hanged right at `ldap_int_select'. The string
`ldap_int_select' appears three times in the output.

I also found this issue #3304 in OpenLDAP ITS:
http://www.openldap.org/its/index.cgi/Software%20Bugs?id=3304;selectid=3304

Isn't it related, too? It is said to be fixed in ver. 2.2.18 and I remember the
version from Fedora (the above mentioned one that worked fine) I used was
slightly newer than this.

Well, I should surely try to apply the patch, it's a few lines so could be
applied by hand if patching fails. I think I'll do this sometimes during the
following week. Should I forget, please bug me by mail. (It might be better to
use my business address as I'm in a usual huge delay with my personal one; it is
`travnicj at feec.vutbr.cz' then.)
Comment 6 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-07-09 21:49:29 EDT
Created attachment 132156 [details]
`ldapsearch' output up to a hang

This is the output of hanging `ldapsearch'. It starts with a prompt (including
the executed command) and ends with another one. The program had to be
terminated, of course, to get tge final prompt.

It should be possible to rerun the command to repeat the test if needed, unless
we have some access restriction set on the NetWare servers. (It's not
impossible to arrange some exceptions, though, if they are needed.)
Comment 7 RHEL Product and Program Management 2006-08-18 13:41:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Jay Turner 2006-08-28 21:28:41 EDT
QE ack for 4.5.
Comment 9 Jay Fenlason 2007-01-31 15:40:30 EST
According to the changelog, this has been fixed since 2.2.13-5.4E 

Note You need to log in before you can comment on or make changes to this bug.