Bug 1576858 - python3-lib389 lacks openssl-perl requirement
Summary: python3-lib389 lacks openssl-perl requirement
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-base
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: mreynolds
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 14:51 UTC by Matus Honek
Modified: 2020-09-13 22:09 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.4.0.9-2.f28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 18:19:34 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 2722 0 None None None 2020-09-13 22:09:47 UTC

Description Matus Honek 2018-05-10 14:51:50 UTC
Description of problem:
An upstream change [1] requires openssl-perl to be installed. This has been reflected in the upstream SPEC file but not in the Fedora one.

[1] https://pagure.io/389-ds-base/issue/49538

Version-Release number of selected component (if applicable):
python3-lib389-1.4.0.9-1

How reproducible:
Always

Steps to Reproduce:
1. Try running enable_tls() function of lib389.
2. The function fails to run /usr/bin/c_rehash as it is not present.

Actual results:
openssl-perl is not installed as a dependency of python3-lib389

Expected results:
openssl-perl is not installed as a dependency of python3-lib389


Note You need to log in before you can comment on or make changes to this bug.