Bug 15769 - Anaconda installer fails during FTP install over PCMCIA
Anaconda installer fails during FTP install over PCMCIA
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-08 17:05 EDT by Coy Krill
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-10 19:29:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Coy Krill 2000-08-08 17:05:15 EDT
Installing via FTP using the PCMCIA image diskette results in an error just
after selecting the location of the boot image.

Setup:
	FTP server: non-anonymous with CD1 ISO image mounted via loop1
	Installing PC: Compaq Prosignia 165 with Compaq EtherNet adapter.

The following is the complete text of the anacdump.txt file:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/textw/lilo_text.py", line
177, in __call__
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/lilo.py", line 181, in
getLiloImages
  File "/usr/lib/anaconda/isys.py", line 136, in checkBoot
    return _isys.checkBoot (path)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
path: /tmp/hda5

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iurlinstall
UrlInstallMethod
p4
(dp5
S'baseUrl'
p6
S'ftp://ckrill:xxxxxxxx@205.253.66.9/mnt'
sbsS'initlevel'
p7
I3
sS'skipLilo'
p8
I0
sS'progressWindow'
p9
NsS'expert'
p10
I0
sS'ddruidReadOnly'
p11
I0
sS'bootdisk'
p12
I0
sS'language'
p13
(itodo
Language
(dp14
S'abbrevMap'
p15
(dp16
S'es_ES'
p17
S'Spanish'
p18
sS'tr_TR'
p19
S'Turkish'
p20
sS'sr_YU'
p21
S'Serbian'
p22
sS'de_DE'
p23
S'German'
p24
sS'sk_SK'
p25
S'Slovak'
p26
sS'ru_RU.KOI8-R'
p27
S'Russian'
p28
sS'is_IS'
p29
S'Icelandic'
p30
sS'no_NO'
p31
S'Norwegian'
p32
sS'sv_SE'
p33
S'Swedish'
p34
sS'en_US'
p35
S'English'
p36
sS'it_IT'
p37
S'Italian'
p38
sS'da_DK'
p39
S'Danish'
p40
sS'cs_CZ'
p41
S'Czech'
p42
sS'uk_UA.KOI8-U'
p43
S'Ukrainian'
p44
sS'hu_HU'
p45
S'Hungarian'
p46
sS'fr_FR'
p47
S'French'
p48
sS'sl_SI'
p49
S'Slovenian'
p50
sS'ro_RO'
p51
S'Romanian'
p52
ssS'font'
p53
(dp54
g38
S'lat0-sun16'
sg22
S'cyr-sun16'
sg28
S'cyr-sun16'
sg36
S'None'
sg26
S'lat2-sun16'
sg32
S'lat0-sun16'
sg34
S'lat0-sun16'
sg48
S'None'
sg50
S'lat2-sun16'
sg52
S'lat2-sun16'
sg24
S'None'
sg20
S'lat5-sun16'
sg46
S'lat2-sun16'
sg18
S'None'
sg44
S'cyr-sun16'
sg42
S'lat2-sun16'
sg40
S'lat0-sun16'
sg30
S'lat0-sun16'
ssS'langs'
p55
(dp56
g38
g37
sg22
g21
sg28
g27
sg36
g35
sg26
g25
sg32
g31
sg34
g33
sg48
g47
sg50
g49
sg52
g51
sg24
g23
sg20
g19
sg46
g45
sg18
g17
sg44
g43
sg42
g41
sg40
g39
sg30
g29
ssS'info'
p57
(dp58
S'LANG'
p59
g35
ssS'map'
p60
(dp61
g38
S'iso15'
sg22
S'iso05'
sg28
S'koi8-r'
sg36
S'None'
sg26
S'iso02'
sg32
S'iso15'
sg34
S'iso15'
sg48
S'None'
sg50
S'iso02'
sg52
S'iso02'
sg24
S'None'
sg20
S'iso09'
sg46
S'iso02'
sg18
S'None'
sg44
S'koi8-u'
sg42
S'iso02'
sg40
S'iso15'
sg30
S'iso15'
ssS'lang'
p62
g35
sbsS'fstab'
p63
NsS'lilo'
p64
(ililo
LiloConfiguration
p65
(dp66
S'liloDevice'
p67
S'mbr'
p68
sS'initrdsMade'
p69
(dsS'edd'
p70
I0
sS'default'
p71
NsS'liloImages'
p72
(dsS'liloLinear'
p73
I1
sS'liloAppend'
p74
NsbsS'comps'
p75
NsS'network'
p76
(itodo
Network
(dp77
S'netdevices'
p78
(dp79
S'eth0'
p80
(itodo
NetworkDevice
(dp81
g57
(dp82
S'BOOTPROTO'
p83
S'dhcp'
sS'ONBOOT'
p84
S'no'
sS'DEVICE'
p85
g80
ssbssS'gateway'
p86
S''
sS'secondaryNS'
p87
S'207.98.129.11'
sS'hostname'
p88
S'rsv-42.qvlinc.com'
sS'primaryNS'
p89
S'205.253.66.2'
sS'domains'
p90
(lp91
S'qvlinc.com'
asS'isConfigured'
p92
I1
sS'readData'
p93
I1
sS'ternaryNS'
p94
S'207.98.129.12'
sbsS'upgrade'
p95
I0
sS'instClass'
p96
(icustom
InstallClass
(dp97
S'rootPasswordCrypted'
p98
I0
sS'nameserver'
p99
S''
sS'x'
NsS'rootPassword'
p100
NsS'makeBootdisk'
p101
I0
sS'installType'
p102
NsS'postScript'
p103
NsS'earlySwapOn'
p104
I0
sS'networkDevice'
p105
NsS'clearText'
p106
Nsg64
(g68
I1
S''
tsg13
NsS'name'
p107
S''
sS'postInChroot'
p108
I0
sS'pixmap'
p109
S''
sS'partitions'
p110
(lsS'clearType'
p111
Nsg86
S''
sS'mouse'
p112
NsS'packages'
p113
NsS'timezone'
p114
NsS'zeroMbr'
p115
I0
sS'keyboard'
p116
NsS'groups'
p117
NsS'bootProto'
p118
NsS'netmask'
p119
S''
sS'raidList'
p120
(lsS'skipSteps'
p121
(dsS'auth'
p122
(I1
I1
I0
S''
I0
S''
I0
I0
S''
S''
I0
S''
S''
S''
I0
S''
S''
tsg88
Nsg63
(lsS'showgroups'
p123
NsS'ip'
p124
S''
sS'defaultRunlevel'
p125
NsS'desktop'
p126
S''
sS'clearPartText'
p127
NsS'clearParts'
p128
I0
sbsS'rootpassword'
p129
(itodo
Password
(dp130
S'pure'
p131
NsS'crypt'
p132
NsbsS'extraModules'
p133
(lp134
sg112
(imouse
Mouse
p135
(dp136
S'device'
p137
S'psaux'
p138
sg57
(dp139
S'XMOUSETYPE'
p140
S'PS/2'
p141
sS'FULLNAME'
p142
S'Generic - 3 Button Mouse (PS/2)'
p143
sS'MOUSETYPE'
p144
S'ps/2'
p145
ssS'emu'
p146
I0
sS'wasProbed'
p147
I1
sS'emulate'
p148
I0
sbsS'ddruidAlreadySaved'
p149
I0
sS'serial'
p150
I0
sg114
Nsg115
I0
sg116
(ikbd
Keyboard
(dp151
S'layout'
p152
NsS'model'
p153
NsS'type'
p154
S'PC'
p155
sg57
(dp156
S'KEYBOARDTYPE'
p157
S'pc'
p158
sS'KEYTABLE'
p159
S'us-latin1'
p160
ssbsS'skipFdisk'
p161
I1
sS'fdDevice'
p162
S'fd0'
p163
sS'installSystem'
p164
I1
sS'setupFilesystems'
p165
I1
sg122
(itodo
Authentication
(dp166
S'useNIS'
p167
I0
sS'nisServer'
p168
S''
sS'useLdap'
p169
I0
sS'krb5Kdc'
p170
S''
sS'useHesiod'
p171
I0
sS'ldapServer'
p172
S''
sS'nisDomain'
p173
S''
sS'krb5Realm'
p174
S''
sS'useLdapauth'
p175
I0
sS'hesiodRhs'
p176
S''
sS'useShadow'
p177
I1
sS'nisuseBroadcast'
p178
I0
sS'useKrb5'
p179
I0
sS'useMD5'
p180
I1
sS'ldapBasedn'
p181
S''
sS'krb5Admin'
p182
S''
sS'hesiodLhs'
p183
S''
sS'hesiodDlhs'
p184
S''
sbsg88
NsS'reconfigOnly'
p185
I0
sS'x'
(ixf86config
XF86Config
(dp186
S'monlist'
p187
(dsS'keyModel'
p188
S'pc101'
p189
sS'monids'
p190
(dsg137
NsS'monEisa'
p191
NsS'server'
p192
NsS'monHoriz'
p193
S'31.5'
p194
sS'devID'
p195
NsS'modes'
p196
(dp197
S'8'
(lp198
S'640x480'
p199
assS'keyOptions'
p200
S''
sS'keyVariant'
p201
S''
sS'monID'
p202
S'Unprobed Monitor'
p203
sS'keyLayout'
p204
S'us'
p205
sg112
g135
sS'keyRules'
p206
S'xfree86'
p207
sS'monVert'
p208
S'60'
p209
sS'cardMan'
p210
NsS'monSect'
p211
S''
sS'primary'
p212
I0
sS'vidRam'
p213
NsS'probed'
p214
I0
sS'monName'
p215
NsS'vidCards'
p216
(lsS'skip'
p217
I0
sS'files'
p218
S'\012# The location of the RGB database.  Note, this is the name of
the\012# file minus the extension (like ".txt" or ".db").  There is
normally\012# no need to change the default.\012\012   
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and
later now use a font server independent of\012# the X server to render
fonts.\012\012    FontPath   "/usr/X11R6/lib/X11/fonts/TrueType"\012   
FontPath   "unix/:7100"\012'
p219
sbsS'users'
p220
(lsS'instPath'
p221
S'/mnt/sysimage'
p222
sS'intf'
p223
NsS'hdList'
p224
Nsb.
Comment 1 Brock Organ 2000-08-10 19:29:11 EDT
hmmm ... I could not reproduce this problem in our test lab here:

1) mounted disc1 ISO image via loopback on our server
2) mounted disc1 CDROM image via /dev/scd0

in both cases, I was unable to get a traceback during the LILO screens
(performing a minimum custom install)
Comment 2 Brock Organ 2000-08-14 15:06:47 EDT
did you create a composite tree (ie the RPMs from both CDs in the RPM directory
in your FTP tree ...?) ... If not, I am wondering if you tried selecting a
package that is on CD #2 while only having the RPMs from CD #1 in the tree ...
Comment 3 Coy Krill 2000-08-22 13:32:23 EDT
No I didn't combine the two CD's.  I'll try that on my next attempt.

Note You need to log in before you can comment on or make changes to this bug.