Bug 1576909 - chromium-browser throws GL errors, no GPU acceleration?
Summary: chromium-browser throws GL errors, no GPU acceleration?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: chromium
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-10 16:49 UTC by Paul DeStefano
Modified: 2018-06-19 18:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-19 18:28:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul DeStefano 2018-05-10 16:49:13 UTC
Description of problem:

I see these on STDERR when starting chromium-browser:

[3006517:3006517:0510/093838.527849:ERROR:gl_implementation.cc(292)] Failed to load /usr/lib64/chromium-browser/swiftshader/libGLESv2.so: /usr/lib6
4/chromium-browser/swiftshader/libGLESv2.so: cannot open shared object file: No such file or directory                                            
[3006517:3006517:0510/093838.530074:ERROR:viz_main_impl.cc(197)] Exiting GPU process due to errors during initialization
[3006361:3006483:0510/093840.179782:ERROR:service_manager_context.cc(252)] Attempting to run unsupported native service: /usr/lib64/chromium-browser/content_gpu.service
[3006361:3006483:0510/093840.186656:ERROR:browser_gpu_channel_host_factory.cc(120)] Failed to launch GPU process.                                 
[3006361:3006361:0510/093840.186722:ERROR:gpu_process_transport_factory.cc(1019)] Lost UI shared context.                                         

Version-Release number of selected component (if applicable):


How reproducible:
I don't know, I just noticed these, but I think they've been going on for a long time.


Additional info:
I'm not really sure if this is supposed to work or not.  But, I have Radeon RX 480.

Comment 1 Akarshan Biswas 2018-05-10 16:52:21 UTC
Might be related to this bug? https://bugs.chromium.org/p/chromium/issues/detail?id=719213

Comment 2 Paul DeStefano 2018-05-10 17:05:16 UTC
Interesting.  My browser doesn't show anything for vendor, so I'm not sure if it's the same thing or not.  Clearly not the same symptoms.

GPU0	VENDOR = 0x1002, DEVICE= 0x67df
Optimus	false
Optimus	false
AMD switchable	false
Driver vendor	
Driver version	
Driver date

Comment 3 Akarshan Biswas 2018-05-10 17:16:13 UTC
Swiftshader allows gpu acceleration on unsupported systems by rendering the 3D graphics entirely on cpu. The fix is to temporarily disable swiftshader by passing "enable_swiftshader=false" as gn arguments and building until the fix lands in stable builds.

Also this bug is amdgpu specific and I was a victim of it for a long time.

Comment 4 Tom "spot" Callaway 2018-06-19 18:28:23 UTC
The problem was actually much simpler than that. The chromium package was missing the swiftshader shared library object (swiftshader/libGLESv2.so). I've fixed that in the chromium 67 builds, which is currently in updates (stable) for Fedora 28.


Note You need to log in before you can comment on or make changes to this bug.